summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/utelnetd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/utelnetd')
-rw-r--r--net-misc/utelnetd/Manifest1
-rw-r--r--net-misc/utelnetd/files/utelnetd.initd16
-rw-r--r--net-misc/utelnetd/metadata.xml8
-rw-r--r--net-misc/utelnetd/utelnetd-0.1.9-r1.ebuild32
4 files changed, 57 insertions, 0 deletions
diff --git a/net-misc/utelnetd/Manifest b/net-misc/utelnetd/Manifest
new file mode 100644
index 000000000000..53b9b1711996
--- /dev/null
+++ b/net-misc/utelnetd/Manifest
@@ -0,0 +1 @@
+DIST utelnetd-0.1.9.tar.gz 15310 SHA256 fbc182ef314681b90a4f73049c6bf332dc93b7cbebbf39a6086a126ed2787346
diff --git a/net-misc/utelnetd/files/utelnetd.initd b/net-misc/utelnetd/files/utelnetd.initd
new file mode 100644
index 000000000000..fe87e80f6798
--- /dev/null
+++ b/net-misc/utelnetd/files/utelnetd.initd
@@ -0,0 +1,16 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+start() {
+ ebegin "Starting utelnetd"
+ start-stop-daemon -b --start --quiet --exec /usr/sbin/utelnetd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping utelnetd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/utelnetd
+ eend $?
+}
diff --git a/net-misc/utelnetd/metadata.xml b/net-misc/utelnetd/metadata.xml
new file mode 100644
index 000000000000..6c730730ce44
--- /dev/null
+++ b/net-misc/utelnetd/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+<longdescription>This is a small telnet daemon for standalone use, mostly on embedded systems.</longdescription>
+</pkgmetadata>
diff --git a/net-misc/utelnetd/utelnetd-0.1.9-r1.ebuild b/net-misc/utelnetd/utelnetd-0.1.9-r1.ebuild
new file mode 100644
index 000000000000..a7b58fc0458c
--- /dev/null
+++ b/net-misc/utelnetd/utelnetd-0.1.9-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="A small Telnet daemon, derived from the Axis tools"
+HOMEPAGE="http://www.pengutronix.de/software/utelnetd_en.html"
+SRC_URI="http://www.pengutronix.de/software/utelnetd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~s390 ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/shadow"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/(STRIP)/d" \
+ -e "/^CC/s:=.*:= $(tc-getCC):" \
+ Makefile || die
+}
+
+src_install() {
+ dosbin utelnetd || die
+ dodoc ChangeLog README
+
+ newinitd "${FILESDIR}"/utelnetd.initd utelnetd
+}