summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/vmnet
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/vmnet')
-rw-r--r--net-misc/vmnet/Manifest2
-rw-r--r--net-misc/vmnet/metadata.xml7
-rw-r--r--net-misc/vmnet/vmnet-0.4.ebuild46
3 files changed, 55 insertions, 0 deletions
diff --git a/net-misc/vmnet/Manifest b/net-misc/vmnet/Manifest
new file mode 100644
index 000000000000..a0e53669a3a0
--- /dev/null
+++ b/net-misc/vmnet/Manifest
@@ -0,0 +1,2 @@
+DIST vmnet-0.4.tar.gz 11362 RMD160 dc58a2bb48a38b9da99ac529798548de7f58dd6e SHA1 49c0e4cb70fdd56b79937e0650dd0c6c2c090b8a SHA256 80c7148200bffa239e3daae79332a18c28409a5ef92ce631d41e2859a9011765
+DIST vmnet_0.4-1.diff.gz 5084 RMD160 6a783781706350c7c21dc00392c16f2447ed28b1 SHA1 997805f34ba773176c32d4622bd69302e2e5798c SHA256 fb01abcbc384025365ff50b35ca3e7777cc4a9a62f353c04d16f4c867332e453
diff --git a/net-misc/vmnet/metadata.xml b/net-misc/vmnet/metadata.xml
new file mode 100644
index 000000000000..c6d862855eb5
--- /dev/null
+++ b/net-misc/vmnet/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/net-misc/vmnet/vmnet-0.4.ebuild b/net-misc/vmnet/vmnet-0.4.ebuild
new file mode 100644
index 000000000000..bfb3a316f368
--- /dev/null
+++ b/net-misc/vmnet/vmnet-0.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A simple virtual networking program - SLIP over stdin/out"
+HOMEPAGE="ftp://ftp.xos.nl/pub/linux/vmnet/"
+# The main site is often down
+# So this might be better but it's a different filename
+# http://ftp.debian.org/debian/pool/main/${PN:0:1}/${PN}/${P/-/_}.orig.tar.gz
+# We use the debian patch anyway
+SRC_URI="ftp://ftp.xos.nl/pub/linux/${PN}/${P}.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${P/-/_}-1.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="sys-apps/net-tools"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ epatch "${DISTDIR}"/${P/-/_}-1.diff.gz
+}
+
+src_compile() {
+ append-ldflags -Wl,-z,now
+ emake || die "Emake failed"
+}
+
+src_install() {
+ dobin ${PN} || die "dobin"
+ fperms 4711 /usr/bin/${PN} || die "fperms"
+
+ doman ${PN}.1
+ dodoc README debian/${PN}.sgml
+
+ insinto /etc
+ doins debian/${PN}.conf
+}
+
+pkg_postinst() {
+ einfo "Don't forgot to ensure SLIP support is in your kernel!"
+}