summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-01-02 20:43:31 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-01-02 20:45:56 +0100
commit38e53c2df01940da65e045f5d6b2185b671f9eb0 (patch)
treeedc588238dd21e7ac7faf706c2aa19b4c3ed06f1 /net-misc/wget
parentsci-misc/oww: Remove old (diff)
downloadgentoo-38e53c2df01940da65e045f5d6b2185b671f9eb0.tar.gz
gentoo-38e53c2df01940da65e045f5d6b2185b671f9eb0.tar.bz2
gentoo-38e53c2df01940da65e045f5d6b2185b671f9eb0.zip
net-misc/wget: Don't use bashisms in configure
Reported-by: Matt Whitlock <gentoo@mattwhitlock.name> Closes: https://bugs.gentoo.org/762946 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-misc/wget')
-rw-r--r--net-misc/wget/files/wget-1.21-avoid_bashisms.patch26
-rw-r--r--net-misc/wget/files/wget-1.21-avoid_eautoreconf.patch11
-rw-r--r--net-misc/wget/wget-1.21-r1.ebuild4
3 files changed, 40 insertions, 1 deletions
diff --git a/net-misc/wget/files/wget-1.21-avoid_bashisms.patch b/net-misc/wget/files/wget-1.21-avoid_bashisms.patch
new file mode 100644
index 000000000000..478621ecb594
--- /dev/null
+++ b/net-misc/wget/files/wget-1.21-avoid_bashisms.patch
@@ -0,0 +1,26 @@
+From a9092887e0e98877a205e9052930692f35fb179e Mon Sep 17 00:00:00 2001
+From: Matt Whitlock <gentoo@mattwhitlock.name>
+Date: Sat, 2 Jan 2021 16:27:57 +0100
+Subject: [PATCH] configure.ac: Don't use bashisms
+
+Gentoo-bug: https://bugs.gentoo.org/762946
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 96adf13b..f6268fd5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -978,7 +978,7 @@ AM_CONDITIONAL([IRI_IS_ENABLED], [test "X$iri" != "Xno"])
+ AM_CONDITIONAL([WITH_SSL], [test "X$with_ssl" != "Xno"])
+ AM_CONDITIONAL([METALINK_IS_ENABLED], [test "X$with_metalink" != "Xno"])
+ AM_CONDITIONAL([WITH_XATTR], [test "X$ENABLE_XATTR" != "Xno"])
+-AM_CONDITIONAL([WITH_NTLM], [test "X$ENABLE_NTLM" == "Xyes"])
++AM_CONDITIONAL([WITH_NTLM], [test "X$ENABLE_NTLM" = "Xyes"])
+
+ dnl
+ dnl Create output
+--
+2.30.0
+
diff --git a/net-misc/wget/files/wget-1.21-avoid_eautoreconf.patch b/net-misc/wget/files/wget-1.21-avoid_eautoreconf.patch
new file mode 100644
index 000000000000..0e02851a2577
--- /dev/null
+++ b/net-misc/wget/files/wget-1.21-avoid_eautoreconf.patch
@@ -0,0 +1,11 @@
+--- a/configure
++++ b/configure
+@@ -55925,7 +55925,7 @@
+ WITH_XATTR_FALSE=
+ fi
+
+- if test "X$ENABLE_NTLM" == "Xyes"; then
++ if test "X$ENABLE_NTLM" = "Xyes"; then
+ WITH_NTLM_TRUE=
+ WITH_NTLM_FALSE='#'
+ else
diff --git a/net-misc/wget/wget-1.21-r1.ebuild b/net-misc/wget/wget-1.21-r1.ebuild
index 9d919f50edbc..392b9c4337c1 100644
--- a/net-misc/wget/wget-1.21-r1.ebuild
+++ b/net-misc/wget/wget-1.21-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit flag-o-matic python-any-r1 toolchain-funcs
@@ -56,6 +56,8 @@ DOCS=( AUTHORS MAILING-LIST NEWS README doc/sample.wgetrc )
PATCHES=(
"${FILESDIR}"/${P}-gnulib-utime-errno.patch # 763123, drop next release
+ "${FILESDIR}"/${PN}-1.21-avoid_bashisms.patch #762946
+ "${FILESDIR}"/${PN}-1.21-avoid_eautoreconf.patch
)
pkg_setup() {