summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-09 08:47:30 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-09 08:47:44 +0100
commit77e90c549e8397adb6ab53915cc3d4958699e4a7 (patch)
treeaaa13c09cd41eb4aab105277333c06200a472a35 /net-misc/whatportis/whatportis-0.6.ebuild
parentmedia-video/vlc: Removed old. (diff)
downloadgentoo-77e90c549e8397adb6ab53915cc3d4958699e4a7.tar.gz
gentoo-77e90c549e8397adb6ab53915cc3d4958699e4a7.tar.bz2
gentoo-77e90c549e8397adb6ab53915cc3d4958699e4a7.zip
net-misc/whatportis: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'net-misc/whatportis/whatportis-0.6.ebuild')
-rw-r--r--net-misc/whatportis/whatportis-0.6.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/whatportis/whatportis-0.6.ebuild b/net-misc/whatportis/whatportis-0.6.ebuild
new file mode 100644
index 000000000000..152867fb50bb
--- /dev/null
+++ b/net-misc/whatportis/whatportis-0.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A command to search port names and numbers"
+HOMEPAGE="http://github.com/ncrocfer/whatportis http://pypi.python.org/pypi/whatportis"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/click-6.2[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
+ >=dev-python/tinydb-3.1.2[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-3.8.1[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${EPYTHON}" test_${PN}.py || die
+}
+
+pkg_postinst() {
+ optfeature "Run ${PN} as a Server" dev-python/flask
+}