summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-28 21:23:53 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-10-29 15:06:32 +0200
commita630c6eaaf5a17419028c4e311380e2423fcc9c1 (patch)
treec459353199cca715fdc9f78b467165799b8458b0 /net-misc/wol
parentdev-tcltk/expect: Stabilize 5.45.4-r3 sparc, #878645 (diff)
downloadgentoo-a630c6eaaf5a17419028c4e311380e2423fcc9c1.tar.gz
gentoo-a630c6eaaf5a17419028c4e311380e2423fcc9c1.tar.bz2
gentoo-a630c6eaaf5a17419028c4e311380e2423fcc9c1.zip
net-misc/wol: additional build fixes
- Try harder to convince it we've got a decent malloc & realloc (if upstream were alive, it'd be worth fixing up the autoconf here, but...) - Fix build with newer linux-headers(?) Closes: https://bugs.gentoo.org/874420 Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-misc/wol')
-rw-r--r--net-misc/wol/files/wol-0.7.1-linux-headers.patch11
-rw-r--r--net-misc/wol/wol-0.7.1-r4.ebuild (renamed from net-misc/wol/wol-0.7.1-r3.ebuild)3
2 files changed, 14 insertions, 0 deletions
diff --git a/net-misc/wol/files/wol-0.7.1-linux-headers.patch b/net-misc/wol/files/wol-0.7.1-linux-headers.patch
new file mode 100644
index 000000000000..e381d2a31a6a
--- /dev/null
+++ b/net-misc/wol/files/wol-0.7.1-linux-headers.patch
@@ -0,0 +1,11 @@
+--- a/src/magic.c
++++ b/src/magic.c
+@@ -142,7 +142,7 @@ magic_assemble (struct magic *magic_buf, const char *mac_str,
+ }
+
+ for (j = 0; j < MAC_LEN; ++j)
+- m[j] = ea.ETHER_ADDR_OCTET[j];
++ m[j] = ea.ether_addr_octet[j];
+ }
+
+ /* accommodate the packet chunk's size to the packet type */
diff --git a/net-misc/wol/wol-0.7.1-r3.ebuild b/net-misc/wol/wol-0.7.1-r4.ebuild
index 3bcd9963ecdb..1ead57765ef2 100644
--- a/net-misc/wol/wol-0.7.1-r3.ebuild
+++ b/net-misc/wol/wol-0.7.1-r4.ebuild
@@ -18,6 +18,7 @@ PATCHES=(
"${FILESDIR}/${P}-musl.patch"
"${FILESDIR}/${P}-Fix-config.h-test-consumption.patch"
"${FILESDIR}/${P}-Fix-malloc-detection.patch"
+ "${FILESDIR}/${P}-linux-headers.patch"
)
src_prepare() {
@@ -28,6 +29,8 @@ src_prepare() {
}
src_configure() {
+ export jm_cv_func_working_{re,m}alloc=yes
+
local myeconfargs=(
--disable-rpath
$(use_enable nls)