summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-08-27 22:01:44 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-08-27 22:59:12 +0200
commita9d1b1f359f8913a436f9f83d62d155916c40271 (patch)
treec65c767b66ca1ca166979b4d3e7f47e2e9a4b6fe /net-misc/wol
parentsys-fs/zfs: drop old rc (diff)
downloadgentoo-a9d1b1f359f8913a436f9f83d62d155916c40271.tar.gz
gentoo-a9d1b1f359f8913a436f9f83d62d155916c40271.tar.bz2
gentoo-a9d1b1f359f8913a436f9f83d62d155916c40271.zip
net-misc/wol: fix compilation with musl
Closes: https://bugs.gentoo.org/712558 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-misc/wol')
-rw-r--r--net-misc/wol/files/wol-0.7.1-musl.patch17
-rw-r--r--net-misc/wol/wol-0.7.1-r2.ebuild2
2 files changed, 19 insertions, 0 deletions
diff --git a/net-misc/wol/files/wol-0.7.1-musl.patch b/net-misc/wol/files/wol-0.7.1-musl.patch
new file mode 100644
index 000000000000..c7c0dc6028ca
--- /dev/null
+++ b/net-misc/wol/files/wol-0.7.1-musl.patch
@@ -0,0 +1,17 @@
+--- a/lib/getline.h
++++ b/lib/getline.h
+@@ -27,6 +27,7 @@
+ # endif
+ # endif
+
++# if defined (__GLIBC__)
+ # if __GLIBC__ < 2
+ int
+ getline PARAMS ((char **_lineptr, size_t *_n, FILE *_stream));
+@@ -34,5 +35,6 @@
+ int
+ getdelim PARAMS ((char **_lineptr, size_t *_n, int _delimiter, FILE *_stream));
+ # endif
++# endif
+
+ #endif /* not GETLINE_H_ */
diff --git a/net-misc/wol/wol-0.7.1-r2.ebuild b/net-misc/wol/wol-0.7.1-r2.ebuild
index 8ee1f1db4070..67f55caf695e 100644
--- a/net-misc/wol/wol-0.7.1-r2.ebuild
+++ b/net-misc/wol/wol-0.7.1-r2.ebuild
@@ -14,6 +14,8 @@ SLOT="0"
KEYWORDS="amd64 arm ppc ppc64 x86"
IUSE="nls"
+PATCHES=( "${FILESDIR}/${P}-musl.patch" )
+
src_configure() {
local myeconfargs=(
--disable-rpath