summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <sudinave@gmail.com>2021-04-14 07:12:52 -0400
committerJoonas Niilola <juippis@gentoo.org>2021-04-15 09:38:54 +0300
commit9d02b021fb62f75f7df091530f19b0582aa601af (patch)
tree20e3fdb1a7652f39a4a371988cd0378152ce42ca /net-misc/x11-ssh-askpass
parentnet-misc/vncrec: fix build with -native-symlinks (diff)
downloadgentoo-9d02b021fb62f75f7df091530f19b0582aa601af.tar.gz
gentoo-9d02b021fb62f75f7df091530f19b0582aa601af.tar.bz2
gentoo-9d02b021fb62f75f7df091530f19b0582aa601af.zip
net-misc/x11-ssh-askpass: fix build with -native-symlinks
Closes: https://bugs.gentoo.org/725200 Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-misc/x11-ssh-askpass')
-rw-r--r--net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.4.1-r2.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.4.1-r2.ebuild b/net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.4.1-r2.ebuild
index 65c9a6691948..4d294cbd5075 100644
--- a/net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.4.1-r2.ebuild
+++ b/net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.4.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,16 +21,16 @@ RDEPEND="virtual/ssh
x11-libs/libXt"
DEPEND="${RDEPEND}"
BDEPEND="app-text/rman
- x11-misc/imake"
+ >=x11-misc/imake-1.0.8-r1"
src_configure() {
econf --libexecdir=/usr/"$(get_libdir)"/misc \
--disable-installing-app-defaults
- xmkmf || die "xmkmf failed"
+ CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
+ IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf -a || die "xmkmf failed"
}
src_compile() {
- emake includes
emake CC="$(tc-getCC)" CDEBUGFLAGS="${CFLAGS}"
}