summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-09-24 12:03:29 -0400
committerCraig Andrews <candrews@gentoo.org>2021-09-24 12:06:09 -0400
commit8e9b3c1e60fb2085321b140d56c69e58452415e0 (patch)
tree57ad7a0a031f3987ff17ea5c23bc5c9d8d3e309f /net-misc/xmrig
parentnet-misc/stunnel: Stabilize 5.59 sparc, #814557 (diff)
downloadgentoo-8e9b3c1e60fb2085321b140d56c69e58452415e0.tar.gz
gentoo-8e9b3c1e60fb2085321b140d56c69e58452415e0.tar.bz2
gentoo-8e9b3c1e60fb2085321b140d56c69e58452415e0.zip
net-misc/xmrig: add USE=opencl
Thank you: Kevin Thomas <me@kevinthomas.dev> Bug: https://github.com/gentoo/gentoo/pull/22382 Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-misc/xmrig')
-rw-r--r--net-misc/xmrig/metadata.xml3
-rw-r--r--net-misc/xmrig/xmrig-6.15.1-r1.ebuild5
-rw-r--r--net-misc/xmrig/xmrig-9999.ebuild9
3 files changed, 12 insertions, 5 deletions
diff --git a/net-misc/xmrig/metadata.xml b/net-misc/xmrig/metadata.xml
index db67f3fd0d2b..c01c676279c9 100644
--- a/net-misc/xmrig/metadata.xml
+++ b/net-misc/xmrig/metadata.xml
@@ -24,6 +24,9 @@
<flag name="hwloc">
Use <pkg>sys-apps/hwloc</pkg> for CPU affinity support
</flag>
+ <flag name="opencl">
+ Enable OpenCL support
+ </flag>
</use>
<upstream>
<remote-id type="github">xmrig/xmrig</remote-id>
diff --git a/net-misc/xmrig/xmrig-6.15.1-r1.ebuild b/net-misc/xmrig/xmrig-6.15.1-r1.ebuild
index 8ad79070a47b..2639977e5a05 100644
--- a/net-misc/xmrig/xmrig-6.15.1-r1.ebuild
+++ b/net-misc/xmrig/xmrig-6.15.1-r1.ebuild
@@ -18,11 +18,12 @@ fi
LICENSE="Apache-2.0 GPL-3+ MIT"
SLOT="0"
-IUSE="cpu_flags_x86_sse4_1 donate hwloc +ssl"
+IUSE="cpu_flags_x86_sse4_1 donate hwloc opencl +ssl"
DEPEND="
dev-libs/libuv:=
hwloc? ( sys-apps/hwloc:= )
+ opencl? ( virtual/opencl )
ssl? ( dev-libs/openssl:= )
"
RDEPEND="
@@ -47,7 +48,7 @@ src_configure() {
-DWITH_SSE4_1=$(usex cpu_flags_x86_sse4_1)
-DWITH_HWLOC=$(usex hwloc)
-DWITH_TLS=$(usex ssl)
- -DWITH_OPENCL=OFF
+ -DWITH_OPENCL=$(usex opencl)
-DWITH_CUDA=OFF
)
diff --git a/net-misc/xmrig/xmrig-9999.ebuild b/net-misc/xmrig/xmrig-9999.ebuild
index 97dc2905531c..2639977e5a05 100644
--- a/net-misc/xmrig/xmrig-9999.ebuild
+++ b/net-misc/xmrig/xmrig-9999.ebuild
@@ -18,11 +18,12 @@ fi
LICENSE="Apache-2.0 GPL-3+ MIT"
SLOT="0"
-IUSE="cpu_flags_x86_sse4_1 donate hwloc +ssl"
+IUSE="cpu_flags_x86_sse4_1 donate hwloc opencl +ssl"
DEPEND="
dev-libs/libuv:=
hwloc? ( sys-apps/hwloc:= )
+ opencl? ( virtual/opencl )
ssl? ( dev-libs/openssl:= )
"
RDEPEND="
@@ -30,7 +31,9 @@ RDEPEND="
!arm64? ( sys-apps/msr-tools )
"
-PATCHES=( "${FILESDIR}"/${PN}-6.12.2-nonotls.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.12.2-nonotls.patch
+)
src_prepare() {
if ! use donate ; then
@@ -45,7 +48,7 @@ src_configure() {
-DWITH_SSE4_1=$(usex cpu_flags_x86_sse4_1)
-DWITH_HWLOC=$(usex hwloc)
-DWITH_TLS=$(usex ssl)
- -DWITH_OPENCL=OFF
+ -DWITH_OPENCL=$(usex opencl)
-DWITH_CUDA=OFF
)