summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-07-22 06:45:54 +0200
committerJeroen Roovers <jer@gentoo.org>2016-07-22 06:45:54 +0200
commit078215a65bcc1dbd3c4f612ed163deb1d4738830 (patch)
treed7007a8c81d605ee8cc23bbc612f3fe4bed5a37f /net-misc/youtube-dl
parentdev-python/psutil: version bump to 4.3.0 (diff)
downloadgentoo-078215a65bcc1dbd3c4f612ed163deb1d4738830.tar.gz
gentoo-078215a65bcc1dbd3c4f612ed163deb1d4738830.tar.bz2
gentoo-078215a65bcc1dbd3c4f612ed163deb1d4738830.zip
net-misc/youtube-dl: Version bump.
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2016.07.17.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 8fc3a78dcb2b..fbbeab180c61 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2016.01.01.tar.gz 1874602 SHA256 732f37c99d71b4239d72d61dd32214b5a5a618671fb0629c8f8deb28209a172c SHA512 fdb022bed426250e5ee1c2bcc1354dd195c0f9793ca479ca8ca4cfe2f71e07ba100b0dbcda2fb9f310308ab130587d06b16a6a86f9036f0d196b317d2e5b5e92 WHIRLPOOL 152e709ba15264c35a89644ea0d4793bb47c82b317e54043ccfff72e40bdf95e42d76605e801233632d3863537a945cfb9ecc2f75245171b8de31b51ce6af801
DIST youtube-dl-2016.07.11.tar.gz 2277011 SHA256 f661957cf1f52bfa7b621cf1b02c0200862a7931e92e25cd984a9c302c3e4d87 SHA512 7c112b238f65a7e4029204f06fa42c67c2fa5d370dc1d796c8fe83d0f585b355e2dfdebc8312bb082acbc72e98b0969b9894c0fba9297016eca2ac09d14b7c51 WHIRLPOOL 19b542560d7044783160671b40187b33b0034a5770bacef8c68d9e490e40bb1af47a1c4e7ebb2b1eb208963b6d3f8732899a2cf1c90e4ce7fbb347dc9dd2b5f6
DIST youtube-dl-2016.07.13.tar.gz 2279744 SHA256 16cda6c8151445b90d3c43412788ff0bb7176e7d7d2a4325642b0e8113249443 SHA512 d0564f724e6b62ee65c48ee9db953101cc2045a2f4b66960be5be135bc61b0249553f74b6bd9f797cc6660109a4a266e43bf9a8646bbe3a8d806b5c022a96ee3 WHIRLPOOL 14720370cc11291d9f192d71ba3bdf241422e3331881e37f86165153f87ca636cc181ee2db8cc5cc9ed7b14c6eac0f2a910387159f421e5131cce4894fc92c82
+DIST youtube-dl-2016.07.17.tar.gz 2288138 SHA256 a87d716b796df153a3561107a935d96c2b049507a09c0a02a4039e751ae63e33 SHA512 20349a25d15259509dfd34837b8938e050c7fd5da7566f435d83ccd76c02bf3ccce79ade1f3e97f2fe08dfe90473fe2e3cad754482f524fd8961fd1324d66025 WHIRLPOOL 128f2c7849669eff58bacc6d11f89f8758524cf615457a099e5b37707d23ca208ad98f587f68c4ec360ef27a310024f65883e2731039b1fb241e535423cc05aa
diff --git a/net-misc/youtube-dl/youtube-dl-2016.07.17.ebuild b/net-misc/youtube-dl/youtube-dl-2016.07.17.ebuild
new file mode 100644
index 000000000000..9d7ca82d0e68
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2016.07.17.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate drtuber eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 pornhd pornotube pornovoisines pornoxo redtube
+ ruleporn sexu slutload spankbang spankwire sunporno thisav trutube
+ tube8 vporn watchindianporn xbef xnxx xtube xvideos xxxymovies
+ youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ pornhub xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+}