summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-12-26 12:07:19 +0100
committerJeroen Roovers <jer@gentoo.org>2015-12-26 12:08:41 +0100
commit29781305a3f10c67e5f21ab2d08244b7e1151979 (patch)
treecebba5c4baf4c49284c94b1e789a76c07316990c /net-misc/youtube-dl
parentapp-admin/lastpass-cli: re-add libressl support (diff)
downloadgentoo-29781305a3f10c67e5f21ab2d08244b7e1151979.tar.gz
gentoo-29781305a3f10c67e5f21ab2d08244b7e1151979.tar.bz2
gentoo-29781305a3f10c67e5f21ab2d08244b7e1151979.zip
net-misc/youtube-dl: Version bump.
Package-Manager: portage-2.2.26
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2015.12.23.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 78096692c049..6b349ecd7f03 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -2,3 +2,4 @@ DIST youtube-dl-2015.04.03.tar.gz 1472296 SHA256 0521a15a24a9b620728a2f45ea9163c
DIST youtube-dl-2015.11.27.1.tar.gz 1803857 SHA256 35a7b2947200209bef9e642d1203e9d4a4103e279222c3ca3b5ee3adf3c8c535 SHA512 7771ed739568a52b0168e095eb97b943b82c6ee463a662f5cf94c40fce4f51ad0ca6d09c2569393b1d09568b63859b1837d247c9994c5134ad79af18bb5aa1ad WHIRLPOOL 5fedcea551ba8637773367d46f78d8e68110c993eb12eda31028b1a38bca3b9928c62ea4519da3ba70f3a7aa62948820d892d4ff3d8d38b2bd847b1348183f33
DIST youtube-dl-2015.12.13.tar.gz 1837788 SHA256 9c788925865ff559b6c9f124d35aed1125046efda7c6a386f0da59d4eac2ead8 SHA512 039778326955ee126ce18ebe9133c9fca03d3fd14bbb56ebff50335e47ce2b24b9ddc8558c35bb4596692ee03b415f72bc238a74bd3034de7ed80a869cc4d64a WHIRLPOOL 806b8898e4ee9c0c79fe0276375ef8e43fbe55c993e8f70f1f321c529f768aeef8a9dc32ca818849f1ad658a072f1b49c13f25a8ee71d3b5eef29d8b9ac7b865
DIST youtube-dl-2015.12.21.tar.gz 1849071 SHA256 7a61ccbc3cd55e712b2fb94a7dedff5052548bbebab9f8c441feec8a02748d4d SHA512 36ad04ccd539a2c63d39e59444033e3eb8d9e2265b769869e54d598ec4a956e3ede939a23fad6531682d0166869b88fd728368a81064690af3f197a45b92b5aa WHIRLPOOL 561239e3c48e75f1e393961d78aeecc2a45058d56bb42ab07accac1d27793cba90a2729424c63f49c50cf9539f683eed069cbdb7ae2bbd45cf0433bc639660b2
+DIST youtube-dl-2015.12.23.tar.gz 1850244 SHA256 fe7088979c78eb900c3db110a577866a01e1dd537cddda25258893f099fff9ba SHA512 e6ca9197b54972ee2a1518c6d76a05c96c0b556a1b0be96bd6fbcf0cccfae4d0555e0aa4c718c6132ca9cb7243f9758b5f28c80be231d702d12a6c32928fb39b WHIRLPOOL fd1dbdb741bc6674b881829b6103b886e0f379b7a5e4d2181f672d445a7a56ceffe6619f114486546e70db3a14b92c7f6ead57586a9d090da77e56d583350b27
diff --git a/net-misc/youtube-dl/youtube-dl-2015.12.23.ebuild b/net-misc/youtube-dl/youtube-dl-2015.12.23.ebuild
new file mode 100644
index 000000000000..5db7401e49ee
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2015.12.23.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
+DISTUTILS_SINGLE_IMPL=true
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink chaturbate drtuber eporner eroprofile
+ extremetube fourtube foxgay goshgay hellporno hentaistigma
+ hornbunny keezmovies mofosex motherless porn91 pornhd pornotube
+ pornovoisines pornoxo redtube sexykarma sexu sunporno slutload
+ spankbang spankwire thisav trutube tube8 vporn xbef xnxx xtube
+ xvideos xxxymovies youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ pornhub xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/__init__.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/__init__.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ youtube_dl/extractor/tumblr.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ python_domodule youtube_dl
+ dobin bin/${PN}
+ dodoc README.txt
+ doman ${PN}.1
+ newbashcomp ${PN}.bash-completion ${PN}
+ python_fix_shebang "${ED}"
+}