summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-08-17 06:52:00 +0200
committerJeroen Roovers <jer@gentoo.org>2015-08-17 06:53:26 +0200
commit34deb98558aef8ddb628eb8b87b5c569f54621e8 (patch)
treeac8486d47b9ce907de18a633413f3628e9597070 /net-misc/youtube-dl
parentdev-python/pytest-runner: add missed dep to DEPEND, bump (diff)
downloadgentoo-34deb98558aef8ddb628eb8b87b5c569f54621e8.tar.gz
gentoo-34deb98558aef8ddb628eb8b87b5c569f54621e8.tar.bz2
gentoo-34deb98558aef8ddb628eb8b87b5c569f54621e8.zip
net-misc/youtube-dl: Version bump.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2015.08.16.1.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index af6b4ee926bc..20bfdb8d10b2 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2015.04.03.tar.gz 1472296 SHA256 0521a15a24a9b620728a2f45ea9163ca74660ed443781b6e69b4e06d36d7bf59 SHA512 6b2c85cfa222a31f3462aab583fa98bb92544cd5fb0d395ca0b69a26c24ab174870d02264e058281f09305752d50aa5a06d0d747205499a530b275e3194fc6f9 WHIRLPOOL 391e06ea261f92e03a0b38618307f1c9d53a2dfb9f2062fe0cd3ded1ea0c411033a17ded581616032c74a9e4fb398a57e565bf847196a23a9f89433f861362ae
DIST youtube-dl-2015.08.09.tar.gz 1694525 SHA256 01bd26ceb7bfde7bef2528666807241354087cf01b198b3d48623ee5e3c4b746 SHA512 16e805081e4ca090c577120dea81b180cc96ff86bdf2e0cd0e76cb2857babba307f375a3605f184af76b7a359c1d15d867c79585d2918c537aa6a8450aaa5dd8 WHIRLPOOL 5e41826a3b2edc3b0949a35fe7671e93490760480deb0454d04578be2fe07f12be391b7057ccf84fc621c93e339bf6bb03e43e1c09b67de553eed5262418483e
+DIST youtube-dl-2015.08.16.1.tar.gz 1706324 SHA256 feaa7b8e4b361cc824e64e0dbe521c3ddc6aab8b417b5491bc2914bfad42e711 SHA512 d88dda697dae1ffb65fd8eb387906dc5ec6c483fe7b2ec72c271fab638b5e4a5d90c629cfc19acfda1a5a4a165ce61497d063bf8fe391a4b988344ab98e42c4d WHIRLPOOL b024089bda29a96e06bf4d83037cad28524832ecc8ac1151eb47387a73ab849a8b93a01bed5e8a1aede7e00a4868ad85f6aa21c6f30c27d676e6753e0d7250b6
DIST youtube-dl-2015.08.16.tar.gz 1704579 SHA256 85ef29e55989bdde8ea1bf9084484288e2acf91bf9c9d2f6ee08380d427712e6 SHA512 8aada283b7612e2314a1b05798e3cff60251899e1fa71c58b601167871d43c703c1d2a20614f2caec688cc34414d1ba6ae54b9a0ba13d51811c63325b66c29eb WHIRLPOOL 894800215424f5e219dc6457c9143d0fff99b40a7a5d83ee03206b7f2a34fc7efb4e88401c02158b3f0e74d2df662e48a86f33ff6fca05157768dd565caeb187
diff --git a/net-misc/youtube-dl/youtube-dl-2015.08.16.1.ebuild b/net-misc/youtube-dl/youtube-dl-2015.08.16.1.ebuild
new file mode 100644
index 000000000000..f78acdd93f6f
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2015.08.16.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4})
+DISTUTILS_SINGLE_IMPL=true
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="http://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink drtuber eporner eroprofile extremetube
+ fourtube foxgay goshgay hellporno hentaistigma hornbunny keezmovies
+ mofosex motherless porn91 pornhd pornotube pornovoisines pornoxo
+ redtube sexykarma sexu sunporno slutload spankbang spankwire thisav
+ trutube tube8 vporn xbef xnxx xtube xvideos xxxymovies youjizz
+ youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ pornhub xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/__init__.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/__init__.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ youtube_dl/extractor/tumblr.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ python_domodule youtube_dl
+ dobin bin/${PN}
+ dodoc README.txt
+ doman ${PN}.1
+ newbashcomp ${PN}.bash-completion ${PN}
+ python_fix_shebang "${ED}"
+}