summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-12-23 11:54:51 +0100
committerJeroen Roovers <jer@gentoo.org>2015-12-23 11:54:51 +0100
commit42eb6bccef22898c1a367502e872fa80d3c0e70d (patch)
tree2ba720c195ebcc6a19c1d3eb3724457ead38fdf0 /net-misc/youtube-dl
parentdev-php/pecl-xdiff: EAPI 5 bump (requires a revbump). (diff)
downloadgentoo-42eb6bccef22898c1a367502e872fa80d3c0e70d.tar.gz
gentoo-42eb6bccef22898c1a367502e872fa80d3c0e70d.tar.bz2
gentoo-42eb6bccef22898c1a367502e872fa80d3c0e70d.zip
net-misc/youtube-dl: Version bump by Adrien D (bug #569154).
Package-Manager: portage-2.2.26
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2015.12.21.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index cbb29b841f92..78096692c049 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2015.04.03.tar.gz 1472296 SHA256 0521a15a24a9b620728a2f45ea9163ca74660ed443781b6e69b4e06d36d7bf59 SHA512 6b2c85cfa222a31f3462aab583fa98bb92544cd5fb0d395ca0b69a26c24ab174870d02264e058281f09305752d50aa5a06d0d747205499a530b275e3194fc6f9 WHIRLPOOL 391e06ea261f92e03a0b38618307f1c9d53a2dfb9f2062fe0cd3ded1ea0c411033a17ded581616032c74a9e4fb398a57e565bf847196a23a9f89433f861362ae
DIST youtube-dl-2015.11.27.1.tar.gz 1803857 SHA256 35a7b2947200209bef9e642d1203e9d4a4103e279222c3ca3b5ee3adf3c8c535 SHA512 7771ed739568a52b0168e095eb97b943b82c6ee463a662f5cf94c40fce4f51ad0ca6d09c2569393b1d09568b63859b1837d247c9994c5134ad79af18bb5aa1ad WHIRLPOOL 5fedcea551ba8637773367d46f78d8e68110c993eb12eda31028b1a38bca3b9928c62ea4519da3ba70f3a7aa62948820d892d4ff3d8d38b2bd847b1348183f33
DIST youtube-dl-2015.12.13.tar.gz 1837788 SHA256 9c788925865ff559b6c9f124d35aed1125046efda7c6a386f0da59d4eac2ead8 SHA512 039778326955ee126ce18ebe9133c9fca03d3fd14bbb56ebff50335e47ce2b24b9ddc8558c35bb4596692ee03b415f72bc238a74bd3034de7ed80a869cc4d64a WHIRLPOOL 806b8898e4ee9c0c79fe0276375ef8e43fbe55c993e8f70f1f321c529f768aeef8a9dc32ca818849f1ad658a072f1b49c13f25a8ee71d3b5eef29d8b9ac7b865
+DIST youtube-dl-2015.12.21.tar.gz 1849071 SHA256 7a61ccbc3cd55e712b2fb94a7dedff5052548bbebab9f8c441feec8a02748d4d SHA512 36ad04ccd539a2c63d39e59444033e3eb8d9e2265b769869e54d598ec4a956e3ede939a23fad6531682d0166869b88fd728368a81064690af3f197a45b92b5aa WHIRLPOOL 561239e3c48e75f1e393961d78aeecc2a45058d56bb42ab07accac1d27793cba90a2729424c63f49c50cf9539f683eed069cbdb7ae2bbd45cf0433bc639660b2
diff --git a/net-misc/youtube-dl/youtube-dl-2015.12.21.ebuild b/net-misc/youtube-dl/youtube-dl-2015.12.21.ebuild
new file mode 100644
index 000000000000..7c5ab5b4b433
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2015.12.21.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
+DISTUTILS_SINGLE_IMPL=true
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink drtuber eporner eroprofile extremetube
+ fourtube foxgay goshgay hellporno hentaistigma hornbunny keezmovies
+ mofosex motherless porn91 pornhd pornotube pornovoisines pornoxo
+ redtube sexykarma sexu sunporno slutload spankbang spankwire thisav
+ trutube tube8 vporn xbef xnxx xtube xvideos xxxymovies youjizz
+ youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ pornhub xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/__init__.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/__init__.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ youtube_dl/extractor/tumblr.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ python_domodule youtube_dl
+ dobin bin/${PN}
+ dodoc README.txt
+ doman ${PN}.1
+ newbashcomp ${PN}.bash-completion ${PN}
+ python_fix_shebang "${ED}"
+}