summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-13 20:53:51 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-13 20:53:51 +0100
commit6ba092cba377bca7e7c699a0f1d665ceafb6d108 (patch)
treed65ca1cc4a928ef385ad2b115452cace4e867a89 /net-misc/youtube-dl
parentnet-im/spectrum2: migrate to tmpfiles eclass (diff)
downloadgentoo-6ba092cba377bca7e7c699a0f1d665ceafb6d108.tar.gz
gentoo-6ba092cba377bca7e7c699a0f1d665ceafb6d108.tar.bz2
gentoo-6ba092cba377bca7e7c699a0f1d665ceafb6d108.zip
net-misc/youtube-dl: Bump to 2020.12.14
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2020.12.14.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index a6f99d22c472..e34a9607843a 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -4,3 +4,4 @@ DIST youtube-dl-2020.11.29.tar.gz 3222467 BLAKE2B 6b699689f55fb5b24d9a3fa9b50046
DIST youtube-dl-2020.12.02.tar.gz 3225560 BLAKE2B 953de14c6801a853091625753c0f918e7c6f88b1631ed2d41427fc36cc615830161f860e043ca784b31b1845ecfd0f5a88afcaeca40dc797cd89d36d4762d637 SHA512 5e48e272d957be391cb18960e0b1864b0f2202e26a53491f5c15f6c40bc36e720d80e95955a5a2f889e05f11a999fd311d095b18e5082bb951739c63ffe7565a
DIST youtube-dl-2020.12.05.tar.gz 3228845 BLAKE2B 6186a7d788bb839a7beceb708ddcc629bf111403ac003baa68422122a77d3793148769b0062f8ca2b1d24348d203ba7cd0b1841c2a16f95e0620423b881a83c2 SHA512 c58baa8a95a9bfc09a8f37299fd3061101d29a0662bd1c35f5b4d3d030ac1f06b47ec2f42fdec1759005556a81c43f7d067e9a43622ba06f8817b1a63c52c4a2
DIST youtube-dl-2020.12.12.tar.gz 3225195 BLAKE2B da14fb941fd81f0596a590e7690c2f4786a57d9fbe057743ab2a4a4cabad9978df3352ae1389b89e42673c3ea99e43488741f2d22cbb6274f1fadc5cbb923a47 SHA512 388722cadf500cbcd97b8d92b1ae67d091a5fe79e6bdf19e3a3f94476ef926f7ab57b35ee6d14e2d7a7bf1c72db37535de6c9c6affd32f4c1403902b813d5530
+DIST youtube-dl-2020.12.14.tar.gz 3229047 BLAKE2B 5a54ce2f7f754640c29c9183495c5933340f6d2b94e4bc958eb6590ada08b12b8333d7c61106e1c00d1ef039a7d203382930833d2734f80bf361cf6858ef09f8 SHA512 8a7d96656ef6803afdff90a2c528cdac5354a10996a631c54c722615ccbf879fd5e89b85f9e369cb9d1fd239fc095db4e232a5c420cdd902f5ffbe76f4e3d1a5
diff --git a/net-misc/youtube-dl/youtube-dl-2020.12.14.ebuild b/net-misc/youtube-dl/youtube-dl-2020.12.14.ebuild
new file mode 100644
index 000000000000..04afa74ada09
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2020.12.14.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{6..9})
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://youtube-dl.org/ https://github.com/ytdl-org/youtube-dl/"
+SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+S=${WORKDIR}/${PN}
+
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+SLOT="0"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests nose
+
+src_prepare() {
+ sed -i -e '/flake8/d' Makefile || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ emake offlinetest
+}
+
+python_install_all() {
+ doman youtube-dl.1
+
+ newbashcomp youtube-dl.bash-completion youtube-dl
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+ rm -r "${ED}"/usr/share/doc/youtube_dl || die
+}
+
+pkg_postinst() {
+ elog "youtube-dl(1) / https://bugs.gentoo.org/355661 /"
+ elog "https://github.com/rg3/youtube-dl/blob/master/README.md#faq :"
+ elog
+ elog "youtube-dl works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need ffmpeg (media-video/ffmpeg)."
+ elog "On some sites - most notably YouTube - videos can be retrieved in"
+ elog "a higher quality format without sound. youtube-dl will detect whether"
+ elog "ffmpeg is present and automatically pick the best option."
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
+ elog
+ elog "Downloading MMS and RTSP videos requires either mplayer"
+ elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
+ elog
+ elog "If you want youtube-dl to embed thumbnails from the metadata into the"
+ elog "resulting MP4 files, consider installing media-video/atomicparsley"
+}