summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-07-11 06:55:08 +0200
committerJeroen Roovers <jer@gentoo.org>2016-07-11 06:59:03 +0200
commit7915bf352ebddb9e455c5c14590bcc9616677ad5 (patch)
tree59716530c4900fd29adeb575d824b08b0bc8c953 /net-misc/youtube-dl
parentdev-db/mysql: Drop security vulnerable versions (diff)
downloadgentoo-7915bf352ebddb9e455c5c14590bcc9616677ad5.tar.gz
gentoo-7915bf352ebddb9e455c5c14590bcc9616677ad5.tar.bz2
gentoo-7915bf352ebddb9e455c5c14590bcc9616677ad5.zip
net-misc/youtube-dl: Version bump.
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2016.07.11.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index a4dc2dba5ffc..385c88a4ace8 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2016.01.01.tar.gz 1874602 SHA256 732f37c99d71b4239d72d61dd32214b5a5a618671fb0629c8f8deb28209a172c SHA512 fdb022bed426250e5ee1c2bcc1354dd195c0f9793ca479ca8ca4cfe2f71e07ba100b0dbcda2fb9f310308ab130587d06b16a6a86f9036f0d196b317d2e5b5e92 WHIRLPOOL 152e709ba15264c35a89644ea0d4793bb47c82b317e54043ccfff72e40bdf95e42d76605e801233632d3863537a945cfb9ecc2f75245171b8de31b51ce6af801
DIST youtube-dl-2016.07.07.tar.gz 2264691 SHA256 9e2008db1f00140233ee188674eef96ba11e6e7bb84a51a9140ceb18f1c6942f SHA512 326fcbc721eed2dd652e2d496693bf173f3024cbf9c68345df0bafca362221233f8503e2b26865353fe76ef036d0a9edaa87cb9a91de61582555d86128b8d979 WHIRLPOOL 4320d44dedfc45cf919a9400a7926af384a6e1b53f0ca890a79ec4fb36471c2d92820f875576ac3a7957617b579adfd646aeed9dcecb16ff9ac05d00f6f17861
DIST youtube-dl-2016.07.09.1.tar.gz 2270473 SHA256 244585080738b4ea6374559c55a38d11577d36cccead6cf90a57c15e55500b36 SHA512 d6d77396fd347f0852dbe57208884200d588e7b8428c780b10670d08a3319c5fb791b6138e6cd9d52583db13f6a4cb1fcc4b119d2bc361753907cbe2712f1903 WHIRLPOOL 54660596a21b5d781692db5c7af076091fa157bf3eee17b7961e02129c38e60343abb4baa5bf33ef77ca7ac54d4960160c1d9ea98fc2afa7407603d74e2a1d3b
+DIST youtube-dl-2016.07.11.tar.gz 2277011 SHA256 f661957cf1f52bfa7b621cf1b02c0200862a7931e92e25cd984a9c302c3e4d87 SHA512 7c112b238f65a7e4029204f06fa42c67c2fa5d370dc1d796c8fe83d0f585b355e2dfdebc8312bb082acbc72e98b0969b9894c0fba9297016eca2ac09d14b7c51 WHIRLPOOL 19b542560d7044783160671b40187b33b0034a5770bacef8c68d9e490e40bb1af47a1c4e7ebb2b1eb208963b6d3f8732899a2cf1c90e4ce7fbb347dc9dd2b5f6
diff --git a/net-misc/youtube-dl/youtube-dl-2016.07.11.ebuild b/net-misc/youtube-dl/youtube-dl-2016.07.11.ebuild
new file mode 100644
index 000000000000..9d7ca82d0e68
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2016.07.11.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate drtuber eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 pornhd pornotube pornovoisines pornoxo redtube
+ ruleporn sexu slutload spankbang spankwire sunporno thisav trutube
+ tube8 vporn watchindianporn xbef xnxx xtube xvideos xxxymovies
+ youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ pornhub xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+}