summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-09-08 15:37:16 +0200
committerJeroen Roovers <jer@gentoo.org>2016-09-08 15:37:16 +0200
commit8599a7e3087632386fa5467f471e1bb932d5b547 (patch)
treeb0851b3a34298c513b2132b4b1998bc9d1e8ec87 /net-misc/youtube-dl
parentmedia-libs/harfbuzz: Bump to version 1.3.1 (diff)
downloadgentoo-8599a7e3087632386fa5467f471e1bb932d5b547.tar.gz
gentoo-8599a7e3087632386fa5467f471e1bb932d5b547.tar.bz2
gentoo-8599a7e3087632386fa5467f471e1bb932d5b547.zip
net-misc/youtube-dl: Version bump.
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2016.09.04.1.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 5443f3052579..793c2f564caa 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2016.01.01.tar.gz 1874602 SHA256 732f37c99d71b4239d72d61dd32214b5a5a618671fb0629c8f8deb28209a172c SHA512 fdb022bed426250e5ee1c2bcc1354dd195c0f9793ca479ca8ca4cfe2f71e07ba100b0dbcda2fb9f310308ab130587d06b16a6a86f9036f0d196b317d2e5b5e92 WHIRLPOOL 152e709ba15264c35a89644ea0d4793bb47c82b317e54043ccfff72e40bdf95e42d76605e801233632d3863537a945cfb9ecc2f75245171b8de31b51ce6af801
DIST youtube-dl-2016.08.28.tar.gz 2347325 SHA256 520d913129ef03fb62c3f1a430db257c962da61b534caccbdd3a0b01e7a96487 SHA512 4f19b48cd1a5b55a0f248f0e3165a08118e4f76d08acb55ac6c3200632a22511bb3f09235bb8483302a4ad7a7c86a18abc24e5278d06afcb506fc0d5474b95f5 WHIRLPOOL db50b75f7e95a141a2ae8f1d3a767b21a848fb8483adf3d0452a07bffd4a0f419decd16948a7d3f69f81ce67332642a5a988141c6c93eb626409157540bd18b4
DIST youtube-dl-2016.09.03.tar.gz 2358006 SHA256 4b93e573325bb37d4f660d5f1964f859f5197aea1a9ac8693ec05132c87b8f8c SHA512 52c1dc035bc30d7db5268fcdb24965541f72825aeb05356cd3778b14524824444078f2f51a05c95bc13446ed571f4a0b4c12e869d5cd55970f2c06c2dc19768e WHIRLPOOL ce5f7ccc4a25360ae85eeaf1aedbc8793d8beb42ef5b967d1ab3684a44418a7e965a5d02114df49c61390ac2b43b4a891557ebd218a13b7e14fce08e72560e65
+DIST youtube-dl-2016.09.04.1.tar.gz 2362102 SHA256 3a84cab74d89f3dbe28f24cc8a012a6f7845ffb1b9d7131cd1e58fefaef035dd SHA512 c96bd88d61d078137bf241477b4d617c660fced860e1456694a15518cc83780803c3a14ea05107b5195fd5bb611f2c1a3675407d9a2f21b236995b8e9d544964 WHIRLPOOL 2e833a7cacd464163bbca9eef4c6e5e3841db0225e290025772c467e6e66ebd430f54aea0057ed13706e2a99050dee48e2527b6f611752f2fde1c17f347cd81f
diff --git a/net-misc/youtube-dl/youtube-dl-2016.09.04.1.ebuild b/net-misc/youtube-dl/youtube-dl-2016.09.04.1.ebuild
new file mode 100644
index 000000000000..1e3fe7079813
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2016.09.04.1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate drtuber eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 pornhd pornotube pornovoisines pornoxo redtube
+ ruleporn sexu slutload spankbang spankwire sunporno thisav tube8
+ vporn watchindianporn xbef xnxx xtube xvideos xxxymovies youjizz
+ youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ pornhub xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+}