summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-05 23:35:47 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-05 23:37:41 +0200
commita27a5dfb92de4aed3922446d5521aaf0cafc475e (patch)
tree4b0eaa5b4069016b5a736833efe30c863a502674 /net-misc/youtube-dl
parentdev-python/grpcio: Remove old (diff)
downloadgentoo-a27a5dfb92de4aed3922446d5521aaf0cafc475e.tar.gz
gentoo-a27a5dfb92de4aed3922446d5521aaf0cafc475e.tar.bz2
gentoo-a27a5dfb92de4aed3922446d5521aaf0cafc475e.zip
net-misc/youtube-dl: Bump to 2021.06.06
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2021.06.06.ebuild68
-rw-r--r--net-misc/youtube-dl/youtube-dl-9999.ebuild27
3 files changed, 81 insertions, 15 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index d1e2bb452f12..7390572bbfd3 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,2 +1,3 @@
DIST youtube-dl-2021.04.26.tar.gz 3333530 BLAKE2B cffa09f91a1bbfc5962177133711ec1fce4760ef4a073c01daede2cdc168a10cfd868ca536903127f5a3214aece1c111d1dae23739aac86e765d7ff21903c884 SHA512 d187b537fc71ca8e0c9422404f14bab20f66ee9ea10af40d94e9216a79d6b78c1c535600308d18905c34ede0934dbf4f642f58125e898130ce536bc053aa2a10
DIST youtube-dl-2021.05.16.tar.gz 3336051 BLAKE2B b73206355187a9f61c51749ce01db40757937f79f988a3b81513a5cbe2c854d1b7f2268d7e02c4a0eb3d46c0852990950dfd400acc09f7616aeccb2e8cba6cf9 SHA512 a78ebfc16cc52458e2a036deb48693110f20c046ca3a509be9adbca76d23429953fcf3cd3aab8390a19af747291950bb9261e5339e5cbb0903b98848216c7aca
+DIST youtube-dl-2021.06.06.tar.gz 3336227 BLAKE2B f30252927ddd79062995ec78d45854e1723fe561ca34777fb0a337750bf09c76da8c205af63869c68c6bc09bfe8f6de1d3f5ee240914ae871bb7920076d8d16c SHA512 7b4d453723d03c3fde46451277d5c44be01469ed1b414ce94e782d6228c132c982835805207222862d0d7b8ba162157196f976400fd15cea7ea513e3595aeea3
diff --git a/net-misc/youtube-dl/youtube-dl-2021.06.06.ebuild b/net-misc/youtube-dl/youtube-dl-2021.06.06.ebuild
new file mode 100644
index 000000000000..8ec79bfd981f
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2021.06.06.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://youtube-dl.org/ https://github.com/ytdl-org/youtube-dl/"
+SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+S=${WORKDIR}/${PN}
+
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+SLOT="0"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests nose
+
+src_prepare() {
+ sed -i -e '/flake8/d' Makefile || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ emake offlinetest
+}
+
+python_install_all() {
+ doman youtube-dl.1
+
+ newbashcomp youtube-dl.bash-completion youtube-dl
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+ rm -r "${ED}"/usr/share/doc/youtube_dl || die
+}
+
+pkg_postinst() {
+ elog "youtube-dl(1) / https://bugs.gentoo.org/355661 /"
+ elog "https://github.com/rg3/youtube-dl/blob/master/README.md#faq :"
+ elog
+ elog "youtube-dl works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need ffmpeg (media-video/ffmpeg)."
+ elog "On some sites - most notably YouTube - videos can be retrieved in"
+ elog "a higher quality format without sound. youtube-dl will detect whether"
+ elog "ffmpeg is present and automatically pick the best option."
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
+ elog
+ elog "Downloading MMS and RTSP videos requires either mplayer"
+ elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
+ elog
+ elog "If you want youtube-dl to embed thumbnails from the metadata into the"
+ elog "resulting MP4 files, consider installing media-video/atomicparsley"
+}
diff --git a/net-misc/youtube-dl/youtube-dl-9999.ebuild b/net-misc/youtube-dl/youtube-dl-9999.ebuild
index 718c04ca9f29..429ca7567199 100644
--- a/net-misc/youtube-dl/youtube-dl-9999.ebuild
+++ b/net-misc/youtube-dl/youtube-dl-9999.ebuild
@@ -1,13 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=(python3_{7..9})
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit bash-completion-r1 distutils-r1 git-r3 readme.gentoo-r1
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
DESCRIPTION="Download videos from YouTube.com (and more sites...)"
HOMEPAGE="https://youtube-dl.org/ https://github.com/ytdl-org/youtube-dl/"
@@ -30,7 +27,7 @@ src_prepare() {
src_compile() {
distutils-r1_src_compile
- emake ${PN}.{bash-completion,fish,zsh}
+ emake youtube-dl.{bash-completion,fish,zsh}
}
python_test() {
@@ -40,13 +37,13 @@ python_test() {
python_install_all() {
# no manpage because it requires pandoc to generate
- newbashcomp ${PN}.bash-completion ${PN}
+ newbashcomp youtube-dl.bash-completion youtube-dl
insinto /usr/share/zsh/site-functions
- newins ${PN}.zsh _${PN}
+ newins youtube-dl.zsh _youtube-dl
insinto /usr/share/fish/vendor_completions.d
- doins ${PN}.fish
+ doins youtube-dl.fish
distutils-r1_python_install_all
@@ -55,13 +52,13 @@ python_install_all() {
}
pkg_postinst() {
- elog "${PN}(1) / https://bugs.gentoo.org/355661 /"
- elog "https://github.com/rg3/${PN}/blob/master/README.md#faq :"
+ elog "youtube-dl(1) / https://bugs.gentoo.org/355661 /"
+ elog "https://github.com/rg3/youtube-dl/blob/master/README.md#faq :"
elog
- elog "${PN} works fine on its own on most sites. However, if you want"
+ elog "youtube-dl works fine on its own on most sites. However, if you want"
elog "to convert video/audio, you'll need ffmpeg (media-video/ffmpeg)."
elog "On some sites - most notably YouTube - videos can be retrieved in"
- elog "a higher quality format without sound. ${PN} will detect whether"
+ elog "a higher quality format without sound. youtube-dl will detect whether"
elog "ffmpeg is present and automatically pick the best option."
elog
elog "Videos or video formats streamed via RTMP protocol can only be"
@@ -70,6 +67,6 @@ pkg_postinst() {
elog "Downloading MMS and RTSP videos requires either mplayer"
elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
elog
- elog "If you want ${PN} to embed thumbnails from the metadata into the"
+ elog "If you want youtube-dl to embed thumbnails from the metadata into the"
elog "resulting MP4 files, consider installing media-video/atomicparsley"
}