summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-03-06 16:15:40 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-03-06 16:19:14 -0500
commita95f867c4fff4a78488114c5ff26c732b4229e0f (patch)
tree9232b987c1b64513fd18841684dcf365b190b638 /net-misc/youtube-dl
parentmail-client/evolution: remove prelink files (diff)
downloadgentoo-a95f867c4fff4a78488114c5ff26c732b4229e0f.tar.gz
gentoo-a95f867c4fff4a78488114c5ff26c732b4229e0f.tar.bz2
gentoo-a95f867c4fff4a78488114c5ff26c732b4229e0f.zip
net-misc/youtube-dl: warn about yt-dlp wrapper differences
wrt bug #833872 comment #6 This is similar to what the yt-dlp ebuild itself warns about, but yt-dlp only does it once while here it wouldn't hurt to nag every time given the end goal is make people stop using youtube-dl. Bug: https://bugs.gentoo.org/833872 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/youtube-dl-2021.12.17-r1.ebuild8
-rw-r--r--net-misc/youtube-dl/youtube-dl-9999.ebuild8
2 files changed, 16 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/youtube-dl-2021.12.17-r1.ebuild b/net-misc/youtube-dl/youtube-dl-2021.12.17-r1.ebuild
index 67a646261adf..cbae1a3e9ecc 100644
--- a/net-misc/youtube-dl/youtube-dl-2021.12.17-r1.ebuild
+++ b/net-misc/youtube-dl/youtube-dl-2021.12.17-r1.ebuild
@@ -63,4 +63,12 @@ pkg_postinst() {
ewarn "latest features and site support. youtube-dl is only kept maintained for"
ewarn "compatibility with older software (notably its python module, yt-dlp has"
ewarn "a 'bin/youtube-dl' compatibility wrapper but not for the module)."
+
+ if use yt-dlp; then
+ ewarn
+ ewarn "USE=yt-dlp is enabled, so said compatibility wrapper will be used. Man pages"
+ ewarn "and completions for youtube-dl were still installed but may have slight usage"
+ ewarn "differences and does not read the same configuration files. It is recommended"
+ ewarn "to use the yt-dlp command directly instead."
+ fi
}
diff --git a/net-misc/youtube-dl/youtube-dl-9999.ebuild b/net-misc/youtube-dl/youtube-dl-9999.ebuild
index 68428f716f70..284776e3ee5c 100644
--- a/net-misc/youtube-dl/youtube-dl-9999.ebuild
+++ b/net-misc/youtube-dl/youtube-dl-9999.ebuild
@@ -63,4 +63,12 @@ pkg_postinst() {
ewarn "latest features and site support. youtube-dl is only kept maintained for"
ewarn "compatibility with older software (notably its python module, yt-dlp has"
ewarn "a 'bin/youtube-dl' compatibility wrapper but not for the module)."
+
+ if use yt-dlp; then
+ ewarn
+ ewarn "USE=yt-dlp is enabled, so said compatibility wrapper will be used. Man pages"
+ ewarn "and completions for youtube-dl were still installed but may have slight usage"
+ ewarn "differences and does not read the same configuration files. It is recommended"
+ ewarn "to use the yt-dlp command directly instead."
+ fi
}