summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-28 20:59:26 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-28 20:59:26 +0100
commitb85e23e7be4b831bbb154d60cb8cbdf6e91c0e45 (patch)
tree010bbda6b071eeb4ceb838bfd43f273c4c81fec9 /net-misc/youtube-dl
parentnet-misc/dhcpcd-ui: Bump to version 0.7.8 (diff)
downloadgentoo-b85e23e7be4b831bbb154d60cb8cbdf6e91c0e45.tar.gz
gentoo-b85e23e7be4b831bbb154d60cb8cbdf6e91c0e45.tar.bz2
gentoo-b85e23e7be4b831bbb154d60cb8cbdf6e91c0e45.zip
net-misc/youtube-dl: Bump to 2020.12.29
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2020.12.29.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 62b871acb7cf..2761442f6760 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,2 +1,3 @@
DIST youtube-dl-2020.12.22.tar.gz 3238866 BLAKE2B 8f2f07c59b4d64ed9176bdbfcb858c4f90d7acfe97fad02bf98c517e46fca049421deb764a039466557cfda20d3921535e0e0ae0be4c9afe514a2242a18a45b5 SHA512 2acd7256d3479387db25cc85882da77996cb8fe09a6c6400a9580c1c10317ab72ee18b0e1c2429f533992c41e172f2bbd8c9570daed01578aa971b1ba9d3fbc2
DIST youtube-dl-2020.12.26.tar.gz 3246941 BLAKE2B 7e2c3cea21e10458c1ee3718e9e039301590d8213367229818f36df488865eca7d1e76a27dfc1d4374d15314f271b12fc2c548f43927c724a936399fffa5ac19 SHA512 6a577aa435639af7c5e60183d7548d5f0a74cdea3cb87edaa81dc20ce5ca788ba99f731cbaacffdae74cc10d530e6b8d5b0cfccaf4cb9c2f4cc4f9c540b2d175
+DIST youtube-dl-2020.12.29.tar.gz 3246557 BLAKE2B 94ad5b81e9bfd17a1b05725920dab04f9d2e6e6655cf5df3bd42c443207253251b26f8c969a4baaabce7eb44e4cd2ec04d4ed20ad56569b540f2eba8796da3f9 SHA512 361bb9d60ca1b45887e56d346121412d4a23a7245d2960afdfca55e96d1134ef68126fd1aa5630e6067002de9e704cb70688d12d6e997413f221d28dced4fa81
diff --git a/net-misc/youtube-dl/youtube-dl-2020.12.29.ebuild b/net-misc/youtube-dl/youtube-dl-2020.12.29.ebuild
new file mode 100644
index 000000000000..04afa74ada09
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2020.12.29.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{6..9})
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://youtube-dl.org/ https://github.com/ytdl-org/youtube-dl/"
+SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+S=${WORKDIR}/${PN}
+
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+SLOT="0"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests nose
+
+src_prepare() {
+ sed -i -e '/flake8/d' Makefile || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ emake offlinetest
+}
+
+python_install_all() {
+ doman youtube-dl.1
+
+ newbashcomp youtube-dl.bash-completion youtube-dl
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+ rm -r "${ED}"/usr/share/doc/youtube_dl || die
+}
+
+pkg_postinst() {
+ elog "youtube-dl(1) / https://bugs.gentoo.org/355661 /"
+ elog "https://github.com/rg3/youtube-dl/blob/master/README.md#faq :"
+ elog
+ elog "youtube-dl works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need ffmpeg (media-video/ffmpeg)."
+ elog "On some sites - most notably YouTube - videos can be retrieved in"
+ elog "a higher quality format without sound. youtube-dl will detect whether"
+ elog "ffmpeg is present and automatically pick the best option."
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
+ elog
+ elog "Downloading MMS and RTSP videos requires either mplayer"
+ elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
+ elog
+ elog "If you want youtube-dl to embed thumbnails from the metadata into the"
+ elog "resulting MP4 files, consider installing media-video/atomicparsley"
+}