summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-10-16 08:48:54 +0200
committerJeroen Roovers <jer@gentoo.org>2016-10-16 08:49:52 +0200
commitcafbcf0a4c872b01dffecd40603ee5b156e5f7e0 (patch)
tree2fe0754a5884ef17ba1a8c82a45334f563b3fd05 /net-misc/youtube-dl
parentdev-libs/libpcre: Stable for HPPA PPC64 (bug #592034). (diff)
downloadgentoo-cafbcf0a4c872b01dffecd40603ee5b156e5f7e0.tar.gz
gentoo-cafbcf0a4c872b01dffecd40603ee5b156e5f7e0.tar.bz2
gentoo-cafbcf0a4c872b01dffecd40603ee5b156e5f7e0.zip
net-misc/youtube-dl: Version bump.
Package-Manager: portage-2.3.2
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2016.10.16.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index c20cc8f42fbf..4f8eb1637674 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -2,3 +2,4 @@ DIST youtube-dl-2016.01.01.tar.gz 1874602 SHA256 732f37c99d71b4239d72d61dd32214b
DIST youtube-dl-2016.09.19.tar.gz 2395739 SHA256 276637e83525778a83d0457f6b9fbc29d6109bc8366d43125432ce835d28545e SHA512 a8fb1ce054e25180eab3969c898d976dec157901931b66cddde0fecd55ef322e64c13a70d50de945849cbc4ccbf8be0aede845cbb8ea390bba34f51fec0533bf WHIRLPOOL e58d38e49d58b86d8eb25b40427046955e011bf57b0862c433ebe459c0268905bff67188c03bb612593d15b3d1f3408a95b510ad6f863d0144ee4307ed012aba
DIST youtube-dl-2016.10.07.tar.gz 2425722 SHA256 56be6107275cbdc867e89caf9d20f351d184fdc4fb06d915945fef708086dbce SHA512 59cc697ff3edd0fc70122624d921ecad620a6c8279051c159b52891cf0818f67661de8957ee2e6aba23c347c80aa0ac2ef384bbb1c5a949b5c3f5d8de24ddf11 WHIRLPOOL dfa85b40ca845d5b2fc3c59d5433d9c7720b03b4efdb10c6b8e929e4cb3848523b1413b33abc0aec78c4fe55874da34c22370a7bd94314539eb2b7875b9a068b
DIST youtube-dl-2016.10.12.tar.gz 2429732 SHA256 3e96d144c5abe8016bc771eebbc687947c3332b3f06247d3cfcca1231041bde9 SHA512 bd671aa58784ebe057177b23131664d73ee6cd6a9993359c9689569afb6d0499d598ce95569c70028721d9b8d326698e2934e56bcbb503e1f22919510b3cff68 WHIRLPOOL 08fd6786437d12292d323fb1230da7777453fedd52090fba3b42be402588106b2d2837b4ab438b08b063478023a2137ff783487748cd69e9de9660d93507cbad
+DIST youtube-dl-2016.10.16.tar.gz 2435016 SHA256 0ff39cbc17b4a73957238ab94ff5f05de2b7d833b0af3e2caf1df51eeeeacc60 SHA512 ee69ccc8ccfb77cc686d71fc90bc970b54417a6ec1492c16b5c2c42f0d8a4e740075cdfcf7fe4d4c2addd5bfd0ac14d73b02613dd01f7c3c9dca6dd1d4e127ab WHIRLPOOL 5183f16d760320937027bbd38c14561e90fb7be805982303575ab72b24a00a2c4bfec257538198eddd4b05d2f9c6dc796643bde2c323634a17d1d63d50ef9fbf
diff --git a/net-misc/youtube-dl/youtube-dl-2016.10.16.ebuild b/net-misc/youtube-dl/youtube-dl-2016.10.16.ebuild
new file mode 100644
index 000000000000..1f0ca43a4f19
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2016.10.16.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate drtuber eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 pornhd pornotube pornovoisines pornoxo redtube
+ ruleporn sexu slutload spankbang spankwire sunporno thisav tube8
+ vporn watchindianporn xbef xnxx xtube xvideos xxxymovies youjizz
+ youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ pornhub xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+}