summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-06-07 07:30:36 +0200
committerJeroen Roovers <jer@gentoo.org>2016-06-07 07:33:02 +0200
commite0d901760807b39a1b309ad4eb4f7cd176811f3c (patch)
treef1d9c01d52cff4127e8591676c2d7da73f31d58d /net-misc/youtube-dl
parentdev-ruby/nokogiri: add 1.6.8 (diff)
downloadgentoo-e0d901760807b39a1b309ad4eb4f7cd176811f3c.tar.gz
gentoo-e0d901760807b39a1b309ad4eb4f7cd176811f3c.tar.bz2
gentoo-e0d901760807b39a1b309ad4eb4f7cd176811f3c.zip
net-misc/youtube-dl: Version bump.
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2016.06.03.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index caf439fdda2e..7b0bd3fe43a0 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2016.01.01.tar.gz 1874602 SHA256 732f37c99d71b4239d72d61dd32214b5a5a618671fb0629c8f8deb28209a172c SHA512 fdb022bed426250e5ee1c2bcc1354dd195c0f9793ca479ca8ca4cfe2f71e07ba100b0dbcda2fb9f310308ab130587d06b16a6a86f9036f0d196b317d2e5b5e92 WHIRLPOOL 152e709ba15264c35a89644ea0d4793bb47c82b317e54043ccfff72e40bdf95e42d76605e801233632d3863537a945cfb9ecc2f75245171b8de31b51ce6af801
DIST youtube-dl-2016.05.30.2.tar.gz 2151363 SHA256 1ffb367f65f5f0ebdaaee92db509e49e88cbd27fc83d34e80ec3e9b5a3c797ad SHA512 8baa4fd8da71a91a616bb16320c1dd5f7033b657460e0524e0c1b4daeaa70bdf2109bf710c5388db0f4c71f78495a3030b7e0d589439e5114769c53afb414bf1 WHIRLPOOL ad60d8c16cf7181044af8968c9bc61b3759828c85f05de5bfce145cbb13b5bc83dedb49e2e6b30e57aa2c69b318d6dc4f1ce9f70ccf3c28f614f0cd7446c43b2
DIST youtube-dl-2016.06.02.tar.gz 2152368 SHA256 0a2ce75ec7734b2b251815146f52678240e9f8cedeb00a5da04c85ebae8e1497 SHA512 36a75ca134c8dc70cfca763af552aadc9e4a6a997c62893a770652980c68918244c7f447db4dcc10147704a25c73f3d0a36de436bb881883c5c915f96f1c54b6 WHIRLPOOL ab4a29c741a0abd8b4ca6f359372ef1303467fc5c5a2ec56c6bbf14eb03448b098a42a65fd8271057f2f55c9f7d1bbd67238550ce4ac875993eca5a5a284865e
+DIST youtube-dl-2016.06.03.tar.gz 2155490 SHA256 29d9eb4eeea9c781010ee6111a8d0dc6469b9974fbd76c6c6d1641f3e8d489e2 SHA512 bd810f636c0a840ffd09cf1fe87001c64b4dc749b1a52a6807412bee36646862bbea6204457b4cb27425d2386d3f96a9b00eef674170cb013d12859944e256d7 WHIRLPOOL 6cf36e1f4f6d97613f59f204a94876f09c816d82b306a413833e183ac1c95d5fbd92f1bde70dbc063bd39e753ab43527b41e1a8d04dac7bca58ef1ec9a23ef2e
diff --git a/net-misc/youtube-dl/youtube-dl-2016.06.03.ebuild b/net-misc/youtube-dl/youtube-dl-2016.06.03.ebuild
new file mode 100644
index 000000000000..969c3bf49e3d
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2016.06.03.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
+DISTUTILS_SINGLE_IMPL=true
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate drtuber eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 pornhd pornotube pornovoisines pornoxo redtube
+ ruleporn sexu slutload spankbang spankwire sunporno thisav trutube
+ tube8 vporn watchindianporn xbef xnxx xtube xvideos xxxymovies
+ youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ pornhub xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ python_domodule youtube_dl
+ dobin bin/${PN}
+
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ python_fix_shebang "${ED}"
+}