summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-04-07 09:54:00 +0200
committerJeroen Roovers <jer@gentoo.org>2017-04-07 09:54:00 +0200
commitf761a5a6129bfe54dadb0a4abbd2187b3008fbcc (patch)
treeb8a79317487c83d0b6b2ed53b608b43e7f68b04b /net-misc/youtube-dl
parentapp-admin/mcelog: Drop old (diff)
downloadgentoo-f761a5a6129bfe54dadb0a4abbd2187b3008fbcc.tar.gz
gentoo-f761a5a6129bfe54dadb0a4abbd2187b3008fbcc.tar.bz2
gentoo-f761a5a6129bfe54dadb0a4abbd2187b3008fbcc.zip
net-misc/youtube-dl: Version bump.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2017.04.03.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index b95339de03d3..bfdbcfa5b0ba 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2017.03.16.tar.gz 2631620 SHA256 55df3cbda9cf86e49baf54040340ec74c692bb3d6da3d2f5a1bc1238017dd492 SHA512 f3b8942f6b2be3b1cfd4bddfb74c17bad48c8ef4bea34114970ecb9d65b5a3dcbe71beba6d7c2dbda168371bbb2e8bbaddce58039bd9d158bf23950a2a88123c WHIRLPOOL 8345da00074e62ec9a9c244cb9ef64930fbd0e5e9e5bc1709bfcf56517cc6312031a09523c3016db2a1542c16a0297bea9d6883a201ae94e347e358307e92422
DIST youtube-dl-2017.03.26.tar.gz 2647102 SHA256 321558b19c485b2269c394de5546a8d6c0a876ad57dec5b53e0f677251d8da03 SHA512 24a5c8b85db51efdca828bd5c0b5d1b4e5da8464e627a4cff2c8043be5b73c57d1de962d1d2035f51158cd47785563c8ed3f3d8c83ddd473649ea67844c083a9 WHIRLPOOL 375fe45c8ff4bddbe0445027fdc8b605e016cb5963ce710c880ab926e8f7486ef79f8b482a14487a0b91c09e8f4815e61dd7759fbebdefb2bc350639b1490f73
DIST youtube-dl-2017.04.02.tar.gz 2658223 SHA256 623e1a80d8e479a68c5620798354a4c238bdeba87f7ae2491ad0628195203f8c SHA512 65725701c944e5baa77fe22c8fd75873161c60e376f1c2bb174197d7be62ea2d32ba240b13609ec76454cf5c81e41facd6881a1b45f5be9ca984eb1a56785806 WHIRLPOOL 13ea7c5e40b6e29854365b6a0778e1c0b4675a73901748a9fadfcb0d26828f75a0999fd2a73ab898b1ed391fa9e5341ca0ddf082b0a8603d788d515a48e68361
+DIST youtube-dl-2017.04.03.tar.gz 2661559 SHA256 d313898eae80d4a26a08621088bd8816d176b31f330d7d9d6ce0f71381c0d0fd SHA512 37c54404c19c99e6ac3d221622503a6f4023cc4534b26ac7a012d0077ae706a220905b206aa3530ffaa41a840df1e3a5c098f834fac795bec1397384635a2e8c WHIRLPOOL 1bf75ceacd026cff5030888eb1ea7c0c4e4507cf406b10a089589d83b0cc57fc4c864d9258ac9b244ece6f92932f5e1443a39498b601344dda20357240d2ed1a
diff --git a/net-misc/youtube-dl/youtube-dl-2017.04.03.ebuild b/net-misc/youtube-dl/youtube-dl-2017.04.03.ebuild
new file mode 100644
index 000000000000..0527ae290b0e
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2017.04.03.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5})
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="+offensive test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 porncom pornflip pornhd pornotube pornovoisines
+ pornoxo ruleporn sexu slutload spankbang spankwire sunporno thisav
+ tube8 vporn watchindianporn xbef xnxx xtube xvideos xxxymovies
+ youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ drtuber pornhub redtube tnaflix xhamster
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+}