summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-23 23:54:58 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-23 23:57:48 +0100
commitf8a2d422f9008e8e6803a3f407f6a6ac3a15f404 (patch)
tree62b4ed9a987c14c2e35be5e7a3f8a21c309eb373 /net-misc/youtube-dl
parentnet-misc/dropbox: bump to 89.4.278 (diff)
downloadgentoo-f8a2d422f9008e8e6803a3f407f6a6ac3a15f404.tar.gz
gentoo-f8a2d422f9008e8e6803a3f407f6a6ac3a15f404.tar.bz2
gentoo-f8a2d422f9008e8e6803a3f407f6a6ac3a15f404.zip
net-misc/youtube-dl: Version 2020.01.24
Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2020.01.24.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index d42f3519b715..d8388151866a 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1 +1,2 @@
DIST youtube-dl-2020.01.15.tar.gz 3159264 BLAKE2B 4f7b527e02e5ce6923f66db322c4ba8695e6e2850b7bcf4353914a27c31c7d5d28980b948326585bd2a25b76f4d7e903e8589fe1f137d905aca9ad30d54818d2 SHA512 1b450feef1d6040726f99e482edb6119b66224a98bdec1983f6921f21b08bd8fceb77cff055326b660fb66742815e5e0238807707547ef82b51b9966fdc82be7
+DIST youtube-dl-2020.01.24.tar.gz 3159926 BLAKE2B 0b1be74f74eb0be6cb0a41faf0538110bfc5d1a213fa1c456a6a358096f16ac8768ebd3d4673e523251fd0721a4a0990f061713d32b13c11077e79f8f02989e1 SHA512 8f85a218395d2932b26c7b76d5b03cbdf9a7c541415c8d1b805239b6ab1ca74b94fc497f32052a1d93fe20ac760994975a13551dd8c5319f0549af20b70a1a78
diff --git a/net-misc/youtube-dl/youtube-dl-2020.01.24.ebuild b/net-misc/youtube-dl/youtube-dl-2020.01.24.ebuild
new file mode 100644
index 000000000000..faa91ea76c9b
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2020.01.24.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{2_7,3_{6,7,8}})
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://github.com/ytdl-org/youtube-dl/"
+SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+LICENSE="public-domain"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+SLOT="0"
+IUSE="test"
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ || (
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]
+ )
+"
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake offlinetest
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins ${PN}.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+ rm -r "${ED}"/usr/share/doc/youtube_dl || die
+}
+
+pkg_postinst() {
+ elog "${PN}(1) / https://bugs.gentoo.org/355661 /"
+ elog "https://github.com/rg3/${PN}/blob/master/README.md#faq :"
+ elog
+ elog "${PN} works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need avconf (media-video/libav) or"
+ elog "ffmpeg (media-video/ffmpeg). On some sites - most notably YouTube -"
+ elog "videos can be retrieved in a higher quality format without sound."
+ elog "${PN} will detect whether avconv/ffmpeg is present and"
+ elog "automatically pick the best option."
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
+ elog
+ elog "Downloading MMS and RTSP videos requires either mplayer"
+ elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
+ elog
+ elog "If you want ${PN} to embed thumbnails from the metadata into the"
+ elog "resulting MP4 files, consider installing media-video/atomicparsley"
+}