summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2021-09-06 23:06:42 +0200
committerPiotr Karbowski <slashbeast@gentoo.org>2021-09-06 23:07:19 +0200
commit14d074ba2b72aef12c39dda44c0f550ed6f9f7ad (patch)
tree1ff2a88c4228f26224c8cc505c43894b44ea00c4 /net-misc/yt-dlp
parentlinux-mod.eclass: set CROSS_COMPILE in the environment (diff)
downloadgentoo-14d074ba2b72aef12c39dda44c0f550ed6f9f7ad.tar.gz
gentoo-14d074ba2b72aef12c39dda44c0f550ed6f9f7ad.tar.bz2
gentoo-14d074ba2b72aef12c39dda44c0f550ed6f9f7ad.zip
net-misc/yt-dlp: 2021.9.1 version bump
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'net-misc/yt-dlp')
-rw-r--r--net-misc/yt-dlp/Manifest1
-rw-r--r--net-misc/yt-dlp/yt-dlp-2021.9.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/Manifest b/net-misc/yt-dlp/Manifest
index 7787307fae08..54ca73008f47 100644
--- a/net-misc/yt-dlp/Manifest
+++ b/net-misc/yt-dlp/Manifest
@@ -1 +1,2 @@
DIST yt-dlp-2021.8.10.tar.gz 1807968 BLAKE2B 664f9f5680c18531bb1c194e6e26a31b6be62894a88c6748bf146fbba79164fec6f5e6db017785daf6c8f5a2c1b7cfc0c2ee6c0d437b9d7bb4e1835eff73650f SHA512 fb321d308e634f6358f046762cc3e827b036083b4764d495bbcef253d06ce445152f4a330c51b5aac1eb3b21a8a345fc791f0fdbdc01089ea2a414b1cd457f20
+DIST yt-dlp-2021.9.1.tar.gz 1846252 BLAKE2B 2cb056b89d1c3f5dfe442c96e983b2500185ade621c285669ef513d0fe9af9aabea3ad121344d1c521b6c89eddc77bf7698edb48d92f6f5f7b58b8939c80817d SHA512 26f778bf63b9be9e487b96f098e56abf65c7c7a89e9c5754755cf73d55e441638174d7b0e7220e994e40c0740edbd792e1fee28b44946cab8197dfaae2eee26e
diff --git a/net-misc/yt-dlp/yt-dlp-2021.9.1.ebuild b/net-misc/yt-dlp/yt-dlp-2021.9.1.ebuild
new file mode 100644
index 000000000000..4c0bfc7cd619
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-2021.9.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="A youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~riscv ~x86"
+LICENSE="public-domain"
+SLOT="0"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ media-libs/mutagen[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ media-video/ffmpeg
+
+"
+
+distutils_enable_tests nose
+
+python_test() {
+ # make_lazy_extractors.py tries to rename it out, so fails if it does not exists.
+ mkdir ytdlp_plugins
+ epytest -k 'not download'
+}
+
+python_install_all() {
+ doman yt-dlp.1
+
+ newbashcomp completions/bash/yt-dlp yt-dlp
+
+ insinto /usr/share/zsh/site-functions
+ newins completions/zsh/_yt-dlp _yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ distutils-r1_python_install_all
+
+ rm -rf "${ED}"/usr/share/doc/yt_dlp || die
+}