summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-12-26 21:50:18 -0500
committerIonen Wolkens <ionen@gentoo.org>2021-12-26 21:53:54 -0500
commit6ef9faf8629e619af24b1148a81fae58c67d7b58 (patch)
treed2fd13ab4d128d4d55111376d7c0faca49cec8ec /net-misc/yt-dlp
parentdev-python/redis-py: add 4.1.0 (diff)
downloadgentoo-6ef9faf8629e619af24b1148a81fae58c67d7b58.tar.gz
gentoo-6ef9faf8629e619af24b1148a81fae58c67d7b58.tar.bz2
gentoo-6ef9faf8629e619af24b1148a81fae58c67d7b58.zip
net-misc/yt-dlp: add 2021.12.27
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc/yt-dlp')
-rw-r--r--net-misc/yt-dlp/Manifest1
-rw-r--r--net-misc/yt-dlp/yt-dlp-2021.12.27.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/Manifest b/net-misc/yt-dlp/Manifest
index 9c7bf287e6d1..34ae9be163da 100644
--- a/net-misc/yt-dlp/Manifest
+++ b/net-misc/yt-dlp/Manifest
@@ -1,2 +1,3 @@
DIST yt-dlp-2021.12.1.tar.gz 2064958 BLAKE2B d97bf6bc5d6a97aec05be73dcc00aac6b1aff011c307abcbf604a3bfab06dadfd28401eab8ad26d42b7ec3db778c66e9fa2de09d3e6c28304fd28791532509d9 SHA512 d04e9e5ae36e73923ac79bb98af6e402ba0b4403430cbcc0517e7f446d42b6c637846b11489c0159faf667ab798b937abb9597fb5fba76b6f7b6e2b379bae328
DIST yt-dlp-2021.12.25.tar.gz 2096136 BLAKE2B b40e35f8e7f644051ca80d7d6eeb5d7963e5d0b0c5ffbbc10ed2e4d1f7133a43ec19a715e2ca131fb95ce31c322b952cb13b40adcfe1d8f655e1bd2162ec8329 SHA512 826abb5654527e37454424a949607d2c9934328228566ab0baa89df23ea081c3feb01584a25d0154d30d389d4c10cc7203ad530ddf8472ae70d6e782e3ded490
+DIST yt-dlp-2021.12.27.tar.gz 2102852 BLAKE2B 69a3a9c916771ab2e1b8f86bbc43e03d0543801f587708b638348088d4454aff8ac93420fd8bd2ebb4f493c74acdf23f08a9495dbcdad77d840a95cfece4aa6b SHA512 2c687493736fabe131481d6bf8df13afc1959ac1458675bfe3c4273df7bb64218f84e07ea324b664b0a52c3e39b3e10999e81bc907bfc98a71a28c92dca90737
diff --git a/net-misc/yt-dlp/yt-dlp-2021.12.27.ebuild b/net-misc/yt-dlp/yt-dlp-2021.12.27.ebuild
new file mode 100644
index 000000000000..449b50847e09
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-2021.12.27.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 distutils-r1 optfeature
+
+DESCRIPTION="youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp"
+SRC_URI="mirror://pypi/${P::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ !net-misc/youtube-dl"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # adjust requires for pycryptodome and optional dependencies (bug #828466)
+ sed -ri setup.py \
+ -e "s/'(pycryptodome)x'/'\1'/" \
+ -e "s/'(mutagen|websockets)',?//g" || die
+}
+
+python_test() {
+ epytest -m 'not download' -p no:markdown
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ local sitedir=$(python_get_sitedir)
+ dosym yt_dlp "${sitedir#${EPREFIX}}"/youtube_dl
+}
+
+python_install_all() {
+ dodoc README.md Changelog.md supportedsites.md
+ doman yt-dlp.1
+
+ dobashcomp completions/bash/yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_yt-dlp
+
+ rm -r "${ED}"/usr/share/doc/yt_dlp || die
+
+ newbin - youtube-dl <<-EOF
+ #!/usr/bin/env sh
+ exec yt-dlp --compat-options youtube-dl "\${@}"
+ EOF
+}
+
+pkg_postinst() {
+ optfeature "various features (merging tracks, streamed content)" media-video/ffmpeg
+ has_version media-video/atomicparsley || # allow fallback but don't advertise
+ optfeature "embedding metadata thumbnails in MP4/M4A files" media-libs/mutagen
+
+ if [[ ! ${REPLACING_VERSIONS} ]] ||
+ ver_test ${REPLACING_VERSIONS} -lt 2021.10.22-r2; then
+ elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
+ elog 'as "youtube-dl". This is strictly for compatibility and it is'
+ elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
+ fi
+}