summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-02-22 21:58:15 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-02-22 22:02:17 -0500
commitca60e02081f804b2418dbf993f7dbc4f86ff1646 (patch)
tree4e557fcb4c7a854419817a47b1db545a3257b51d /net-misc/ytfzf
parentsys-process/parallel: use EAPI 8 (diff)
downloadgentoo-ca60e02081f804b2418dbf993f7dbc4f86ff1646.tar.gz
gentoo-ca60e02081f804b2418dbf993f7dbc4f86ff1646.tar.bz2
gentoo-ca60e02081f804b2418dbf993f7dbc4f86ff1646.zip
net-misc/ytfzf: add 2.2
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc/ytfzf')
-rw-r--r--net-misc/ytfzf/Manifest1
-rw-r--r--net-misc/ytfzf/ytfzf-2.2.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/net-misc/ytfzf/Manifest b/net-misc/ytfzf/Manifest
index ed697336c01e..d71a13eb252b 100644
--- a/net-misc/ytfzf/Manifest
+++ b/net-misc/ytfzf/Manifest
@@ -1 +1,2 @@
DIST ytfzf-2.1.tar.gz 3230643 BLAKE2B b296048c976c260b3192f770bdf2dec99f5ad45066deeac23429808254552ea125ea8a8d129c47a5110916c4194f7b7742dd01f095809f4913077600a8205d4b SHA512 a86203bc1dffd05ff3543c44d5612bc8b0ffc675ce0484499cb89aa88c2618c88e832dd95ff2cd6f1803698c1c3264709a1e280ddbb9fb0985c0178f3adc16ea
+DIST ytfzf-2.2.tar.gz 3242266 BLAKE2B 7bc6317ea2ee67ca1d93acc5262d5ebc7f6c9828531f1b97d1fd8e4cfb9e9328cf9955da993d59dcfe05a1a983106cf98f3c93ab4b2c007458154f860e333b55 SHA512 9f47da0e56d096d248b14387c3e34f11cc101fa958945e17bdee83d81c2da57faf384fe87d46132e4cc78a5f4f6057462e28c1a64ea647a98120c37ed4e7f50d
diff --git a/net-misc/ytfzf/ytfzf-2.2.ebuild b/net-misc/ytfzf/ytfzf-2.2.ebuild
new file mode 100644
index 000000000000..1a6d408ced73
--- /dev/null
+++ b/net-misc/ytfzf/ytfzf-2.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="Posix script to find and watch youtube videos from the terminal"
+HOMEPAGE="https://github.com/pystardust/ytfzf/"
+SRC_URI="https://github.com/pystardust/ytfzf/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal"
+
+# fzf/mpv/yt-dlp "can" be optfeatures depending on configuration, but depend
+# on them so it works as expected out-of-the-box while allowing to disable.
+RDEPEND="
+ app-misc/jq
+ net-misc/curl[ssl]
+ virtual/awk
+ !minimal? (
+ app-shells/fzf
+ media-video/mpv[lua]
+ net-misc/yt-dlp
+ )"
+
+src_prepare() {
+ default
+
+ sed -i "/^: ...YTFZF_SYSTEM_ADDON_DIR/s|/usr/local|${EPREFIX}/usr|" ytfzf || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ local emakeargs=(
+ DESTDIR="${D}"
+ PREFIX="${EPREFIX}"/usr
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF}
+ )
+
+ emake "${emakeargs[@]}" addons doc install
+ einstalldocs
+
+ rm -r "${ED}"/usr/share/licenses || die
+}
+
+pkg_postinst() {
+ optfeature "external menu support" x11-misc/dmenu
+ optfeature "in-terminal thumbnails on X11" media-gfx/ueberzug
+ optfeature "desktop notifications" x11-libs/libnotify
+
+ if [[ ${REPLACING_VERSIONS} ]] && ver_test ${REPLACING_VERSIONS} -lt 2.0; then
+ elog "Note that >=${PN}-2.0 is a major rewrite and is not compatible with"
+ elog "configuration and some command arguments of older versions, see the"
+ elog "newly added ${PN}(1) and ${PN}(5) man pages for more information."
+ fi
+}