summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-12-29 23:45:25 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-12-29 23:47:13 +0100
commit0e9b5da0e59765b1f401f370cc6485d2f2791dca (patch)
tree9064640ddc068386da14ca505b60fae6ab16400e /net-misc
parentmedia-libs/alsa-ucm-conf: add 1.2.6.3 (diff)
downloadgentoo-0e9b5da0e59765b1f401f370cc6485d2f2791dca.tar.gz
gentoo-0e9b5da0e59765b1f401f370cc6485d2f2791dca.tar.bz2
gentoo-0e9b5da0e59765b1f401f370cc6485d2f2791dca.zip
net-misc/gallery-dl: bump to 1.20.0
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/gallery-dl/Manifest1
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.20.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/gallery-dl/Manifest b/net-misc/gallery-dl/Manifest
index fd779f03be68..b57763ff5ecd 100644
--- a/net-misc/gallery-dl/Manifest
+++ b/net-misc/gallery-dl/Manifest
@@ -1,3 +1,4 @@
DIST gallery-dl-1.18.1.tar.gz 368692 BLAKE2B f92eb7a876563ed5bc78ca1222b8c45fe78ad6d899a55bf2edefece14209acfc784bc3ac84c7e84397746f5a5ab01c2c6f94efcb0f28d2aacac3cbd68ebcd545 SHA512 20e4f983160870a646a66963505d2c53f5498b9bbbb869a603ae53848ee788f26c6df4c5951805d99f225954ddbe692c2da5501a409650cc3e522d97f34a7c0d
DIST gallery-dl-1.19.2.tar.gz 393664 BLAKE2B cae6b2cdd9f940892032498c0450918481aea22a701b236f580e6c7d2f77b7ce5fb2336a93c882b35063eb0193b9ebb956f8d12e8b6794255318b6eb65ee9de9 SHA512 7aa014e0e84d856bd9ca45131baed513f1d3c73c1500df32c39b5a40f17cd951e80b819130254f9b563a504866e5feebabf6b5c8bf517a43a6ad7a15e41f0476
DIST gallery-dl-1.19.3.tar.gz 399869 BLAKE2B cef40ac7759bffb42536fed866df946e6c22e333ddae98db149109779dd9439c775722b887898e322de26860aee0990a440aa0812620dadb9d223da09f25d662 SHA512 b50c0e341a0b2b08ddd8f5674c1f4df097b862827f8bca2270d3fd62be619fab8a4c097de9d3193e8161ebcb64eb6c77676c243bca4cabc7dc1d3f192b485ad3
+DIST gallery-dl-1.20.0.tar.gz 407372 BLAKE2B 8d7bd6ed4a769b4d4b3357b146babda2ac36989ce1373977b4902ae350a1e430585a5064205fb2038c62727c13c8b09a010aa9e32a96483783229db6366425b6 SHA512 d373b7a104232c99bfae8f92adc3af5ea51e8a1ccfec6db54831de899f9568be0526c8c7cd8f9cdc4680b8dc8934d483c95172b68cffca6b59b605698e2bca65
diff --git a/net-misc/gallery-dl/gallery-dl-1.20.0.ebuild b/net-misc/gallery-dl/gallery-dl-1.20.0.ebuild
new file mode 100644
index 000000000000..885d94ca287f
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.20.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=(python3_{8,9,10})
+PYTHON_REQ_USE="sqlite,ssl,xml"
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+# tests require network access
+RESTRICT="test"
+
+RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py
+
+python_compile_all() {
+ emake PYTHON=${EPYTHON} data/completion/{,_}gallery-dl man
+}
+
+pkg_postinst() {
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/youtube-dl
+}