summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-02-25 16:05:29 +0100
committerJeroen Roovers <jer@gentoo.org>2018-02-25 16:05:29 +0100
commit10c82b31d7f5e10015dcc5bb00aba35a8047f806 (patch)
treee700f7b683fbcc0f3e98921fc148119f43dc8f59 /net-misc
parentmedia-gfx/splashutils: Fix build failure (diff)
downloadgentoo-10c82b31d7f5e10015dcc5bb00aba35a8047f806.tar.gz
gentoo-10c82b31d7f5e10015dcc5bb00aba35a8047f806.tar.bz2
gentoo-10c82b31d7f5e10015dcc5bb00aba35a8047f806.zip
net-misc/youtube-dl: Version 2018.02.25.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2018.02.25.ebuild115
2 files changed, 116 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 4e74c5c7853d..78b29e4abd38 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -2,3 +2,4 @@ DIST youtube-dl-2017.03.16.tar.gz 2631620 BLAKE2B 2aff8710a296140a4329b0f8e7f575
DIST youtube-dl-2017.11.15.tar.gz 2834012 BLAKE2B fd93e3923f99874be58681a886c09e31ac10063975ab636badf27e59b44743c72cddf05e3a431c49ffd0f7b40f9b005f4d90feff85d4ca889dee80833300b076 SHA512 e10c0d53db7fdfb02610b53f54046c0a9354b305ba05c5d00a43649a283a6449263f66ff56171d52cf18f906c6aeccc25dc48ea708b4b1bb2b8323b937abca96
DIST youtube-dl-2018.02.04.tar.gz 2895562 BLAKE2B dd81345019afa82706e3f4ce617b89dc77bc12c904e245bb1605a82dc1ed83805679dd11be056463ad2cb584e1774f43f9e3b8e5e55694c58d7a06fd4e65aea0 SHA512 0f39fbcdc3ae4169fec3938fe4f13466e87ba977921b3af1a61571430b145ead21557962834a4e3d3d2660110ee1772602abc779e8cdd61c3ee57a6638f2418e
DIST youtube-dl-2018.02.11.tar.gz 2901130 BLAKE2B f803cc7a94362e4ff20b57a64383c6751fbf56906c4d3cf8bdc882cd0edf8f74b211212334b9fcb81bedfc3bb0e907a4c1a5089d1d2a2478c2371373f1e415f7 SHA512 74731f346873074cd8e9f45f24f9fb1c0a9f37aabb6aa5fcff5e5e43085cfc700eff384531262a39c453c30cf18f27733b1d02709468906cb787ed3153cf2768
+DIST youtube-dl-2018.02.25.tar.gz 2910276 BLAKE2B f9ec8a0fd091a94153ddfb6952502479fa10f994cd6e8c5357f211209bdb3741c756a51d68b27bc07a5f424f3486171ac6b5a9243e4d72f0492e2f4a0d58aabe SHA512 5cd1bcbfad34019090da33210656e71e72b0fca1c95157a0186a67efbbe2157caff42fc1e4401411376a6b53eaae57fd45e368bb4454773514a5dd5108a341a4
diff --git a/net-misc/youtube-dl/youtube-dl-2018.02.25.ebuild b/net-misc/youtube-dl/youtube-dl-2018.02.25.ebuild
new file mode 100644
index 000000000000..db51a779b025
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2018.02.25.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="+offensive test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/..version../s|'$|+gentoo.no.offensive.sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate eporner
+ eroprofile extremetube foxgay goshgay hellporno hentaistigma
+ hornbunny keezmovies lovehomeporn mofosex myvidster porn91 porncom
+ pornflip pornhd pornotube pornovoisines pornoxo ruleporn sexu
+ slutload spankbang spankwire sunporno thisav tube8 vporn
+ watchindianporn xbef xnxx xtube xvideos xxxymovies youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ drtuber fourtube motherless pornhub redtube tnaflix xhamster
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ eapply_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+ rm -r "${ED}"/usr/share/doc/youtube_dl || die
+}
+
+pkg_postinst() {
+ elog "youtube-dl(1) / https://bugs.gentoo.org/355661 /"
+ elog "https://github.com/rg3/youtube-dl/blob/master/README.md#faq :"
+ elog
+ elog "${PN} works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need avconf (media-video/libav) or"
+ elog "ffmpeg (media-video/ffmpeg). On some sites - most notably YouTube -"
+ elog "videos can be retrieved in a higher quality format without sound."
+ elog "${PN} will detect whether avconv/ffmpeg is present and"
+ elog "automatically pick the best option."
+
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
+ elog "Downloading MMS and RTSP videos requires either mplayer"
+ elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
+}