summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-03-17 20:11:17 +0100
committerJeroen Roovers <jer@gentoo.org>2019-03-17 20:11:31 +0100
commit1aef3eeba8ac2bcfeff9e3aecc459c87712c3907 (patch)
tree5e716ec3178efb19d1d0ff511b32979d32d660e8 /net-misc
parentdev-libs/libzip: 1.5.2 version bump, add USE mbedtls (diff)
downloadgentoo-1aef3eeba8ac2bcfeff9e3aecc459c87712c3907.tar.gz
gentoo-1aef3eeba8ac2bcfeff9e3aecc459c87712c3907.tar.bz2
gentoo-1aef3eeba8ac2bcfeff9e3aecc459c87712c3907.zip
net-misc/youtube-dl: Version 2019.03.18
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2019.03.18.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 7b9dfd1cc64f..be50d86addf9 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,2 +1,3 @@
DIST youtube-dl-2019.03.01.tar.gz 3117441 BLAKE2B 92beb16920b6d9c3ead89d5ff930b73635f74d7aeba62a4ee8159e28b448931810f340857bc223ab587610704405083768137a62d7c92814a7525825adc60919 SHA512 ff037b2288b937ebc70bfa880a4c0cd10cb4a615725e25f8db998c828d4b505461088b5aaa926aa47f148189496275f1a70e03e187325c15d6ff425ed4da2dc7
DIST youtube-dl-2019.03.09.tar.gz 3120854 BLAKE2B 83c9dd22636dec34be497d28e28dcf8e68ad3566603acb5902dc422672aa73e27811bf27779da093e54fcee8068f9a3377eb21e8810f1a3cad95d4bdc920c8a7 SHA512 a827d481057ff502064acd4c170c5320c63e0abb1048ef9d3563083478dc518f0755ecdc3179fe75a1a949aa162f9bebdd96a59f913b34f0b7ed54b168fc2903
+DIST youtube-dl-2019.03.18.tar.gz 3122206 BLAKE2B 8a94cf92ebce960fe9b074d5cc23047fbf326fe4511c55f0a1c4843386e4e3c65da4f89a2401243dbaf73882f68aadc768e653e8ed9e5c91244172c24e55d8bb SHA512 0a683631da7d67aa2f23eb6326664e483b71ef776b3ff63c732bdef54f58c7f615733023f8c4b948078f59d136414bd059bdc753d89aec630126bbe826db58ce
diff --git a/net-misc/youtube-dl/youtube-dl-2019.03.18.ebuild b/net-misc/youtube-dl/youtube-dl-2019.03.18.ebuild
new file mode 100644
index 000000000000..8249fc9c0e19
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2019.03.18.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6,3_7})
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+LICENSE="public-domain"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+RESTRICT="test"
+SLOT="0"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ || (
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ )
+"
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins ${PN}.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+ rm -r "${ED}"/usr/share/doc/youtube_dl || die
+}
+
+pkg_postinst() {
+ elog "${PN}(1) / https://bugs.gentoo.org/355661 /"
+ elog "https://github.com/rg3/${PN}/blob/master/README.md#faq :"
+ elog
+ elog "${PN} works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need avconf (media-video/libav) or"
+ elog "ffmpeg (media-video/ffmpeg). On some sites - most notably YouTube -"
+ elog "videos can be retrieved in a higher quality format without sound."
+ elog "${PN} will detect whether avconv/ffmpeg is present and"
+ elog "automatically pick the best option."
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
+ elog "Downloading MMS and RTSP videos requires either mplayer"
+ elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
+ elog
+ elog "If you want ${PN} to embed thumbnails from the metadata into the"
+ elog "resulting MP4 files, consider installing media-video/atomicparsley"
+}