summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-11-05 15:11:42 +0100
committerMarek Szuba <marecki@gentoo.org>2020-11-05 15:18:05 +0100
commit28c002049ff9906d32d61a3940b53e845fab3bb3 (patch)
tree579a968ebd0c405bd479ba0afa59038a31f9f38e /net-misc
parentnet-libs/nDPI: fail when libpcap can't be found (diff)
downloadgentoo-28c002049ff9906d32d61a3940b53e845fab3bb3.tar.gz
gentoo-28c002049ff9906d32d61a3940b53e845fab3bb3.tar.bz2
gentoo-28c002049ff9906d32d61a3940b53e845fab3bb3.zip
net-misc/linuxptp: fix compilation error
Invoking maintainer time-out. Closes: https://bugs.gentoo.org/728540 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/linuxptp/files/linuxptp-2.0_nettstamp-systypes.patch52
-rw-r--r--net-misc/linuxptp/linuxptp-2.0-r1.ebuild4
2 files changed, 56 insertions, 0 deletions
diff --git a/net-misc/linuxptp/files/linuxptp-2.0_nettstamp-systypes.patch b/net-misc/linuxptp/files/linuxptp-2.0_nettstamp-systypes.patch
new file mode 100644
index 000000000000..d3f8e5d92906
--- /dev/null
+++ b/net-misc/linuxptp/files/linuxptp-2.0_nettstamp-systypes.patch
@@ -0,0 +1,52 @@
+net_tstamp.h needs clockid_t to be defined, so must include
+<sys/types.h> before including <linux/net_tstamp.h>
+
+
+--- a/clock.c
++++ b/clock.c
+@@ -17,6 +17,7 @@
+ * 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+ */
+ #include <errno.h>
++#include <sys/types.h>
+ #include <linux/net_tstamp.h>
+ #include <poll.h>
+ #include <stdlib.h>
+--- a/hwstamp_ctl.c 2018-08-12 23:08:43.000000000 +0200
++++ b/hwstamp_ctl.c 2020-02-07 13:49:53.256859722 +0100
+@@ -23,6 +23,7 @@
+ #include <string.h>
+ #include <sys/ioctl.h>
+ #include <unistd.h>
++#include <sys/types.h>
+
+ #include <arpa/inet.h>
+ #include <linux/net_tstamp.h>
+--- a/sk.c 2018-08-12 23:08:43.000000000 +0200
++++ b/sk.c 2020-02-07 13:50:12.334599236 +0100
+@@ -18,6 +18,7 @@
+ * 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+ */
+ #include <errno.h>
++#include <sys/types.h>
+ #include <linux/net_tstamp.h>
+ #include <linux/sockios.h>
+ #include <linux/ethtool.h>
+--- a/timemaster.c 2018-08-12 23:08:43.000000000 +0200
++++ b/timemaster.c 2020-02-07 13:50:19.848500949 +0100
+@@ -22,7 +22,6 @@
+ #include <errno.h>
+ #include <libgen.h>
+ #include <limits.h>
+-#include <linux/net_tstamp.h>
+ #include <net/if.h>
+ #include <signal.h>
+ #include <spawn.h>
+@@ -34,6 +33,7 @@
+ #include <sys/types.h>
+ #include <sys/wait.h>
+ #include <unistd.h>
++#include <linux/net_tstamp.h>
+
+ #include "print.h"
+ #include "rtnl.h"
diff --git a/net-misc/linuxptp/linuxptp-2.0-r1.ebuild b/net-misc/linuxptp/linuxptp-2.0-r1.ebuild
index 60e25c5dd150..6594c946478c 100644
--- a/net-misc/linuxptp/linuxptp-2.0-r1.ebuild
+++ b/net-misc/linuxptp/linuxptp-2.0-r1.ebuild
@@ -19,6 +19,10 @@ RDEPEND="${DEPEND}"
CONFIG_CHECK="~PPS ~NETWORK_PHY_TIMESTAMPING ~PTP_1588_CLOCK"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0_nettstamp-systypes.patch
+)
+
pkg_setup() {
linux-info_pkg_setup
}