summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-09-25 07:37:04 +0200
committerMichał Górny <mgorny@gentoo.org>2019-09-25 07:52:57 +0200
commit2f78310cdba40c34c7657895e4754f15799c2e0f (patch)
treee39a090bc5231969535d1dd8f3e0fa54c4c18f2f /net-misc
parentdev-python/cmd2: Drop old (diff)
downloadgentoo-2f78310cdba40c34c7657895e4754f15799c2e0f.tar.gz
gentoo-2f78310cdba40c34c7657895e4754f15799c2e0f.tar.bz2
gentoo-2f78310cdba40c34c7657895e4754f15799c2e0f.zip
net-misc/miniupnpd: Bump to 2.1.20190924
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/miniupnpd/Manifest1
-rw-r--r--net-misc/miniupnpd/miniupnpd-2.1.20190924.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/net-misc/miniupnpd/Manifest b/net-misc/miniupnpd/Manifest
index 5e7b552dccfc..86ae703ac63d 100644
--- a/net-misc/miniupnpd/Manifest
+++ b/net-misc/miniupnpd/Manifest
@@ -1 +1,2 @@
DIST miniupnpd-2.1.20190902.tar.gz 240742 BLAKE2B 0b880b1e8a96c56af92726d3fe81da0a26de83861efe4dc266e287623dcac4c6bd4c4ac8d2c6ef7724c1055933d5138e7c86da5c8e3852f2022f69697505f231 SHA512 0abeb9df088ecd57909106fbb43de14d90eebd351a466477777f413f40c49bc432050bc8ea0d655d2eea0bfcedbdb97719ea2476a8bd9170ef9b74ad97217d26
+DIST miniupnpd-2.1.20190924.tar.gz 241008 BLAKE2B 392006e71ede0d18dc1dbfd13c46e591f6675fcb02828461f0afc79b4019f953f62ab95669e92cee4724ff502585420c563d555a7948b0f9d25d755efe6bdb2c SHA512 719a3ac741327691170d7e933b170dcc1399da1958d9373327b96ab5d975290d2bfa0f68d96fbb2ac4b3fb9808b50385291705cd393252263f403d43298c4031
diff --git a/net-misc/miniupnpd/miniupnpd-2.1.20190924.ebuild b/net-misc/miniupnpd/miniupnpd-2.1.20190924.ebuild
new file mode 100644
index 000000000000..8878d99503e2
--- /dev/null
+++ b/net-misc/miniupnpd/miniupnpd-2.1.20190924.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="MiniUPnP IGD Daemon"
+HOMEPAGE="http://miniupnp.free.fr/"
+SRC_URI="http://miniupnp.free.fr/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+leasefile igd2 ipv6 nftables pcp-peer portinuse strict"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ sys-apps/util-linux:=
+ dev-libs/openssl:0=
+ !nftables? (
+ >=net-firewall/iptables-1.4.6:0=[ipv6?]
+ net-libs/libnfnetlink:=
+ net-libs/libmnl:=
+ )
+ nftables? (
+ net-firewall/nftables
+ net-libs/libnftnl:=
+ net-libs/libmnl:=
+ )"
+DEPEND="${RDEPEND}
+ sys-apps/lsb-release"
+
+src_prepare() {
+ default
+
+ # Prevent overriding CFLAGS.
+ sed -i -e '/^CFLAGS =/d' Makefile.linux_nft || die
+
+ mv "Makefile.linux$(usex nftables _nft '')" Makefile || die
+ # meh, we have two Makefiles but genconfig.sh guesses anyway...
+ sed -e "s@\[ -x \"\$(command -v nft)\" \]@$(usex nftables true false)@" \
+ -i genconfig.sh || die
+
+ # Prevent gzipping manpage.
+ sed -i -e '/gzip/d' Makefile || die
+}
+
+src_configure() {
+ local -a opts
+ opts=(
+ --vendorcfg
+ $(usex igd2 '--igd2' '')
+ $(usex ipv6 '--ipv6' '')
+ $(usex leasefile '--leasefile' '')
+ $(usex portinuse '--portinuse' '')
+ $(usex pcp-peer '--pcp-peer' '')
+ $(usex strict '--strict' '')
+ )
+
+ emake CONFIG_OPTIONS="${opts[*]}" config.h
+}
+
+src_compile() {
+ # By default, it builds a bunch of unittests that are missing wrapper
+ # scripts in the tarball
+ emake CC="$(tc-getCC)" STRIP=true miniupnpd
+}
+
+src_install() {
+ emake PREFIX="${ED}" STRIP=true install
+
+ local confd_seds=()
+ if use nftables; then
+ confd_seds+=( -e 's/^iptables_scripts=/#&/' )
+ else
+ confd_seds+=( -e 's/^nftables_scripts=/#&/' )
+ fi
+ if ! use ipv6 || use nftables; then
+ confd_seds+=( -e 's/^ip6tables_scripts=/#&/' )
+ fi
+
+ newinitd "${FILESDIR}"/${PN}-init.d-r2 ${PN}
+ newconfd - ${PN} < <(sed "${confd_seds[@]}" \
+ "${FILESDIR}"/${PN}-conf.d-r2 || die)
+}
+
+pkg_postinst() {
+ elog "Please correct the external interface in the top of the two"
+ elog "scripts in /etc/miniupnpd and edit the config file in there too"
+}