summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-10-13 06:49:54 +0200
committerJeroen Roovers <jer@gentoo.org>2015-10-13 06:52:30 +0200
commit3450233cf393624ec360bc3d70bf1ce8bf3e3f37 (patch)
tree0e07e6f161f73524bec34be383f3a7eebc825031 /net-misc
parentnet-p2p/classified-ads: bump -> -0.09, ebuild by proxy maintainer (diff)
downloadgentoo-3450233cf393624ec360bc3d70bf1ce8bf3e3f37.tar.gz
gentoo-3450233cf393624ec360bc3d70bf1ce8bf3e3f37.tar.bz2
gentoo-3450233cf393624ec360bc3d70bf1ce8bf3e3f37.zip
net-misc/chrony: Version bump.
Package-Manager: portage-2.2.23
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/chrony/Manifest1
-rw-r--r--net-misc/chrony/chrony-2.2_pre2.ebuild114
2 files changed, 115 insertions, 0 deletions
diff --git a/net-misc/chrony/Manifest b/net-misc/chrony/Manifest
index e24ccb55e7cd..3d470ebe7357 100644
--- a/net-misc/chrony/Manifest
+++ b/net-misc/chrony/Manifest
@@ -1,2 +1,3 @@
DIST chrony-2.1.1.tar.gz 391037 SHA256 b0565148eaa38e971291281d76556c32f0138ec22e9784f8bceab9c65f7ad7d4 SHA512 bbb6d4b3436b7c3c7d45628500678ce31291aaa7f59df0f616268fcdb9285f21a79b085d232773ce732eea82f28fa87f4c56ac5b6a7388275c67889daf641499 WHIRLPOOL a431253f173fb8c52f417c0a074c66e3125bb46247b3a177d6ad4c96d953a4557fb159e5940f03d39a83ad1b5a92dd73f84333e3d2274a42a5e93337ca2f6d7e
DIST chrony-2.2-pre1.tar.gz 339418 SHA256 6a850a5d278ee2f28936baeb880f2bcd6774064302c58edff2577b16082de8e5 SHA512 eb77bd681ef4d1133ccfdf9d59b8ee1d161d5816b99e3ec58db9240181ac023f7d6950a7adeb37582abcd1a27f51df6964d41ff0fb2e095f7f0a5b3231386277 WHIRLPOOL 0cb671cabc31b8dfe4ebf4b3635e6591a31f2c7431e5a476d57f108b43b318f23bf8107eeb2038dcd194d574784dac1854f3537432c4ebe81f2d29d61653deec
+DIST chrony-2.2-pre2.tar.gz 339752 SHA256 dd5c9a90b00db399a6199d63a337ee23f4552034fb1697f4cf9903781a49d858 SHA512 86d13831e19d26780b55bb77c5b7b5d57c2136ce5f36cb6d837f0afbeab33999cd8c111c16013e1166c82fe95cd30d7901de491d014d423c88a917692a3a2780 WHIRLPOOL 01ebcf50b7a5e412dbc11ea51115862419a78b34515bdf589ad6b23b5948997c5d13b6244de595358b813f41f10294fe22da18f236a34be6ed0a10b0c258a8ce
diff --git a/net-misc/chrony/chrony-2.2_pre2.ebuild b/net-misc/chrony/chrony-2.2_pre2.ebuild
new file mode 100644
index 000000000000..3b219f232e7b
--- /dev/null
+++ b/net-misc/chrony/chrony-2.2_pre2.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils systemd toolchain-funcs
+
+DESCRIPTION="NTP client and server programs"
+HOMEPAGE="http://chrony.tuxfamily.org/"
+SRC_URI="http://download.tuxfamily.org/${PN}/${P/_/-}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="caps +cmdmon ipv6 libedit +ntp +phc +pps readline +refclock +rtc selinux +adns"
+REQUIRED_USE="
+ ?? ( libedit readline )
+"
+
+CDEPEND="
+ caps? ( sys-libs/libcap )
+ libedit? ( dev-libs/libedit )
+ readline? ( >=sys-libs/readline-4.1-r4:= )
+"
+DEPEND="
+ ${CDEPEND}
+ sys-apps/texinfo
+"
+RDEPEND="
+ ${CDEPEND}
+ selinux? ( sec-policy/selinux-chronyd )
+"
+
+RESTRICT=test
+
+S="${WORKDIR}/${P/_/-}"
+
+src_prepare() {
+ sed -i \
+ -e 's:/etc/chrony\.:/etc/chrony/chrony.:g' \
+ -e 's:/var/run:/run:g' \
+ conf.c chrony.texi.in examples/* || die
+}
+
+src_configure() {
+ tc-export CC
+
+ local CHRONY_EDITLINE
+ # ./configure legend:
+ # --disable-readline : disable line editing entirely
+ # --without-readline : do not use sys-libs/readline (enabled by default)
+ # --without-editline : do not use dev-libs/libedit (enabled by default)
+ if ! use readline && ! use libedit; then
+ CHRONY_EDITLINE='--disable-readline'
+ else
+ CHRONY_EDITLINE+=" $(usex readline '' --without-readline)"
+ CHRONY_EDITLINE+=" $(usex libedit '' --without-editline)"
+ fi
+
+ # not an autotools generated script
+ local CHRONY_CONFIGURE="
+ ./configure \
+ $(usex caps '' --disable-linuxcaps) \
+ $(usex cmdmon '' --disable-cmdmon) \
+ $(usex ipv6 '' --disable-ipv6) \
+ $(usex ntp '' --disable-ntp) \
+ $(usex phc '' --disable-phc) \
+ $(usex pps '' --disable-pps) \
+ $(usex rtc '' --disable-rtc) \
+ $(usex refclock '' --disable-refclock) \
+ $(usex adns '' --disable-asyncdns) \
+ ${CHRONY_EDITLINE} \
+ ${EXTRA_ECONF} \
+ --docdir=/usr/share/doc/${PF} \
+ --chronysockdir=/run/chrony \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --sysconfdir=/etc/chrony \
+ --disable-sechash \
+ --without-nss \
+ --without-tomcrypt
+ "
+
+ # print the ./configure call to aid in future debugging
+ einfo ${CHRONY_CONFIGURE}
+ bash ${CHRONY_CONFIGURE} || die
+}
+
+src_compile() {
+ emake all docs
+}
+
+src_install() {
+ default
+
+ doinfo chrony.info*
+
+ newinitd "${FILESDIR}"/chronyd.init chronyd
+ newconfd "${FILESDIR}"/chronyd.conf chronyd
+
+ insinto /etc/${PN}
+ newins examples/chrony.conf.example1 chrony.conf
+
+ dodoc examples/*.example*
+
+ keepdir /var/{lib,log}/chrony
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/chrony-2.2.logrotate chrony
+
+ systemd_newunit "${FILESDIR}"/chronyd.service-r2 chronyd.service
+ systemd_enable_ntpunit 50-chrony chronyd.service
+}