summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2016-10-24 16:29:05 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2016-10-24 16:44:37 -0700
commit573e4e7200e4d2c23a24ddbe2eb302150aa8b4a4 (patch)
tree5923b436845025b491641c7c79f6e6f10b25d564 /net-misc
parentdev-python/twisted: Version bump (diff)
downloadgentoo-573e4e7200e4d2c23a24ddbe2eb302150aa8b4a4.tar.gz
gentoo-573e4e7200e4d2c23a24ddbe2eb302150aa8b4a4.tar.bz2
gentoo-573e4e7200e4d2c23a24ddbe2eb302150aa8b4a4.zip
net-misc/netifrc: bump, MANY fixes.
This release of netifrc should hopefully represent the next stable candidate. The 0.3.x and 0.4.x series had some bugs that should not be in stable. One specific change to note, is that if an address or route is already configured on an interface, prior to starting the interface service, the interface will now start successfully, whereas it would previously fail. If the parameters on the existing route and new route are slightly different, this may lead to non-deterministic behavior. Bugs fixed: 420941, 588872: l2tp/dummy/hsr support. 487208: support busybox better, no scope=host on loopback. 488250, 488260, 488262: better IPv6 address handling. 489398: more reliable interface startup 507346: resolvconf-gentoo renamed to openresolv 524156: DHCP classless static routes for udhcpc 525958: Better POSIX sh support 540728, 547906: macchanger 1.7 support 545364: Switch to /run instead of /var/run 575128: newer udev support 596234: New iproute keywords: noprefixroute mngtmpaddr 596844: metric_SSID support Package-Manager: portage-2.3.2 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/netifrc/Manifest1
-rw-r--r--net-misc/netifrc/netifrc-0.5.0.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/net-misc/netifrc/Manifest b/net-misc/netifrc/Manifest
index 6e887b7bd548..8946cc729f34 100644
--- a/net-misc/netifrc/Manifest
+++ b/net-misc/netifrc/Manifest
@@ -4,3 +4,4 @@ DIST netifrc-0.2.4.tar.bz2 61828 SHA256 9b53eb3c8e6e80cd4073a34f911a28055c28b9f7
DIST netifrc-0.3.0.tar.bz2 68461 SHA256 9b0bd794a7714c06d2baa11553af018f694c2c71d121e657630d9c9ee94cafc6 SHA512 e28c00e5318c17e46bbdbcd471252729b73a4a0af930a4bf6213d30441650390b6bb83678cfd1fbeddd8102f947016a18976538dcf316cfab08461adf301686c WHIRLPOOL aa868e8b9dccb6d2ba48f37318adae57cf8314d1b45d9ad1fdc5d6b85b0b432b7b3f5b784d9d3ae824612699947b6bd47810c4cf44daf25aef52673a1fa2120c
DIST netifrc-0.3.1.tar.bz2 69213 SHA256 a92a96b6f065981ee1c0232a507f3695230eeb7fb6172ec9048c2538b36cfea8 SHA512 de7d9291c3303e077c86e1fd42c6d9319308f0b51f28a034f9ed830aa504d2830ce96816a391811bcfadd07500e9c439acd4c4365555d7a3e47e58178b53465b WHIRLPOOL b2b0384880abb52a6d31a640688ecbdf17e4ba02aed9660e63c99c80eed315384459984abe1ef527526bed5a142e2c13275b7e7f68332fc6d9368bd98dcdd461
DIST netifrc-0.4.0.tar.bz2 75517 SHA256 cc5c10d567530f64ca8c4fb8dcfc8218d102144f83393e1db769a5a5374c00df SHA512 a6b525a8f084a3cc9e4afa452617c001a225475689ed5ecb86703178eb252b70eb2dfc294789e29c6001098087a7ca2238ff9c8763accf3a66d39cff86614e85 WHIRLPOOL cdaa38a549106a3f73db88aa6376f77d71868cf774a1bb346276a52f6503ccc28f0049d12cbad6e068ab9af87b0fc37e69caa43f31efcbeb4e1a548a6b069c16
+DIST netifrc-0.5.0.tar.bz2 78738 SHA256 2937cd4fd0f0a6eee050b00cc0b32ba37d2793eee09de21e0366d4e0886f8257 SHA512 2348c0df590d6060de3756a5111ac2916047e21ce56d43fc0b8d99946f93ca02ce300abcd9243e1e4cbcd5ab89ea6ed0869785cdb5297a669aeb6812788933b0 WHIRLPOOL 32bca5ecc6a3f6b75e541778b9d0548102c69cc86fb9d61458bc36f458766470489f5bf86b9373e8db598ee0883c65e6986efa2a37d1873484297df9aad73015
diff --git a/net-misc/netifrc/netifrc-0.5.0.ebuild b/net-misc/netifrc/netifrc-0.5.0.ebuild
new file mode 100644
index 000000000000..918a70a6dda8
--- /dev/null
+++ b/net-misc/netifrc/netifrc-0.5.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils systemd udev
+
+DESCRIPTION="Gentoo Network Interface Management Scripts"
+HOMEPAGE="https://www.gentoo.org/proj/en/base/openrc/"
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
+ #EGIT_REPO_URI="git://github.com/gentoo/netifrc" # Alternate
+ inherit git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~robbat2/distfiles/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="kernel_linux? ( virtual/pkgconfig )
+ !<sys-fs/udev-172"
+RDEPEND="sys-apps/gentoo-functions
+ >=sys-apps/openrc-0.12"
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ local ver="git-${EGIT_VERSION:0:6}"
+ sed -i "/^GITVER[[:space:]]*=/s:=.*:=${ver}:" mk/git.mk || die
+ einfo "Producing ChangeLog from Git history"
+ GIT_DIR="${S}/.git" git log >"${S}"/ChangeLog
+ fi
+
+ # Allow user patches to be applied without modifying the ebuild
+ epatch_user
+}
+
+src_compile() {
+ MAKE_ARGS="${MAKE_ARGS}
+ UDEVDIR=${EPREFIX}$(get_udevdir)
+ LIBEXECDIR=${EPREFIX}/lib/${PN} PF=${PF}"
+
+ use prefix && MAKE_ARGS="${MAKE_ARGS} MKPREFIX=yes PREFIX=${EPREFIX}"
+
+ emake ${MAKE_ARGS} all
+}
+
+src_install() {
+ emake ${MAKE_ARGS} DESTDIR="${D}" install
+ dodoc README CREDITS FEATURE-REMOVAL-SCHEDULE STYLE TODO ChangeLog
+
+ # Install the service file
+ LIBEXECDIR=${EPREFIX}/lib/${PN}
+ UNIT_DIR="$(systemd_get_unitdir)"
+ sed "s:@LIBEXECDIR@:${LIBEXECDIR}:" "${S}/systemd/net_at.service.in" > "${T}/net_at.service" || die
+ systemd_newunit "${T}/net_at.service" 'net@.service'
+ dosym "${UNIT_DIR#${EPREFIX}}/net@.service" "${UNIT_DIR#${EPREFIX}}/net@lo.service"
+}
+
+pkg_postinst() {
+ if [[ ! -e "${EROOT}"/etc/conf.d/net && -z $REPLACING_VERSIONS ]]; then
+ elog "The network configuration scripts will use dhcp by"
+ elog "default to set up your interfaces."
+ elog "If you need to set up something more complete, see"
+ elog "${EROOT}/usr/share/doc/${P}/README"
+ fi
+}