summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-30 23:57:22 +0100
committerSam James <sam@gentoo.org>2021-07-31 00:30:09 +0100
commit63b1973563aeecee27ec9a4359b6b33dfcbe6cd6 (patch)
tree287b58c385618220c7203251b6326d83d6e96207 /net-misc
parentnet-misc/dhcp: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-63b1973563aeecee27ec9a4359b6b33dfcbe6cd6.tar.gz
gentoo-63b1973563aeecee27ec9a4359b6b33dfcbe6cd6.tar.bz2
gentoo-63b1973563aeecee27ec9a4359b6b33dfcbe6cd6.zip
net-misc/exabgp: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/exabgp/exabgp-4.2.11-r1.ebuild6
-rw-r--r--net-misc/exabgp/exabgp-4.2.11-r2.ebuild4
2 files changed, 9 insertions, 1 deletions
diff --git a/net-misc/exabgp/exabgp-4.2.11-r1.ebuild b/net-misc/exabgp/exabgp-4.2.11-r1.ebuild
index a61e484d1264..1ec8278c5641 100644
--- a/net-misc/exabgp/exabgp-4.2.11-r1.ebuild
+++ b/net-misc/exabgp/exabgp-4.2.11-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -54,3 +54,7 @@ python_install_all() {
doman doc/man/*.?
}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}
diff --git a/net-misc/exabgp/exabgp-4.2.11-r2.ebuild b/net-misc/exabgp/exabgp-4.2.11-r2.ebuild
index 3e7774c03533..be3a94116ae7 100644
--- a/net-misc/exabgp/exabgp-4.2.11-r2.ebuild
+++ b/net-misc/exabgp/exabgp-4.2.11-r2.ebuild
@@ -57,3 +57,7 @@ python_install_all() {
doman doc/man/*.?
}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}