summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-12-21 15:50:25 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-12-21 15:52:07 +0100
commit6592e05e5c0c7ac3eaea5a994d576ec3c7c9b42b (patch)
tree4249d2d736f32f6fee47285a71510083f78476ed /net-misc
parentsec-policy/selinux-base-policy: Add systemd module unconditionally (diff)
downloadgentoo-6592e05e5c0c7ac3eaea5a994d576ec3c7c9b42b.tar.gz
gentoo-6592e05e5c0c7ac3eaea5a994d576ec3c7c9b42b.tar.bz2
gentoo-6592e05e5c0c7ac3eaea5a994d576ec3c7c9b42b.zip
net-misc/dhcpcd-ui: Bump to version 0.7.7
Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/dhcpcd-ui/Manifest1
-rw-r--r--net-misc/dhcpcd-ui/dhcpcd-ui-0.7.7.ebuild68
-rw-r--r--net-misc/dhcpcd-ui/files/dhcpcd-ui-0.7.7-tinfo.patch25
-rw-r--r--net-misc/dhcpcd-ui/metadata.xml5
4 files changed, 98 insertions, 1 deletions
diff --git a/net-misc/dhcpcd-ui/Manifest b/net-misc/dhcpcd-ui/Manifest
index 7bd37c47ddaf..6048843148c1 100644
--- a/net-misc/dhcpcd-ui/Manifest
+++ b/net-misc/dhcpcd-ui/Manifest
@@ -1 +1,2 @@
DIST dhcpcd-ui-0.7.5.tar.bz2 209112 BLAKE2B 1eec904acefbc5059496419991b1d53c6715d56e611e09d7474879b4ae2741e61ce85bdd7ca32db42a8a890790d8784ee8904fa1228ab43488a88480f73dcd1c SHA512 78dba758f7cee825a1618c33b1fff9549c4e51e19fd5eebd1ae5d6a4686726ec8ad86dc1ec5384238b43589dd700979c694f48bc94e2844f1ef898292660a5d2
+DIST dhcpcd-ui-0.7.7.tar.xz 195648 BLAKE2B f382e331326e66d81674579ba018e6f9a6662df9d10fa0cca92808290e5d7621e7861afaa3d9a2c4d05fcc24b619922f8740faeaf4a531701f5d14505636fdf7 SHA512 46f66c16986c248740b2dc8ce0edb663fbd35809d2d21f701588c3736cdafb32b04c57ffbc6f8974841499ab46f6a1084d0a761b290e9d02ea3a9fae36a0ff3d
diff --git a/net-misc/dhcpcd-ui/dhcpcd-ui-0.7.7.ebuild b/net-misc/dhcpcd-ui/dhcpcd-ui-0.7.7.ebuild
new file mode 100644
index 000000000000..1cdbd71bffff
--- /dev/null
+++ b/net-misc/dhcpcd-ui/dhcpcd-ui-0.7.7.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+DESCRIPTION="Desktop notification and configuration for dhcpcd"
+HOMEPAGE="https://roy.marples.name/projects/dhcpcd-ui/"
+SRC_URI="https://roy.marples.name/downloads/${PN%-ui}/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug gtk gtk2 libnotify ncurses qt5"
+
+REQUIRED_USE="libnotify? ( gtk )
+ qt5? ( !libnotify )"
+
+BDEPEND="
+ virtual/libintl
+"
+DEPEND="
+ gtk? (
+ gtk2? (
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ )
+ !gtk2? (
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ )
+ )
+ libnotify? ( x11-libs/libnotify )
+ ncurses? ( sys-libs/ncurses:0= )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )
+"
+
+RDEPEND="${DEPEND}
+ >=net-misc/dhcpcd-6.4.4"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.7.7-tinfo.patch
+)
+
+src_configure() {
+ local myeconfargs=(
+ --without-qt
+ $(use_enable debug)
+ $(use_enable libnotify notification)
+ $(use_with gtk gtk $(usex gtk2 'gtk+-2.0' 'gtk+-3.0'))
+ $(use_with ncurses curses)
+ $(use_with qt5 qt)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
+
+ systemd_dounit src/dhcpcd-online/dhcpcd-wait-online.service
+}
diff --git a/net-misc/dhcpcd-ui/files/dhcpcd-ui-0.7.7-tinfo.patch b/net-misc/dhcpcd-ui/files/dhcpcd-ui-0.7.7-tinfo.patch
new file mode 100644
index 000000000000..ca7c284e428e
--- /dev/null
+++ b/net-misc/dhcpcd-ui/files/dhcpcd-ui-0.7.7-tinfo.patch
@@ -0,0 +1,25 @@
+From 28eeb5e4a5d92ff913e3956550bff56f615c97df Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Sat, 21 Dec 2019 15:17:56 +0100
+Subject: [PATCH] Fix build against ncurses with separate tinfo lib
+
+---
+ configure | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure b/configure
+index ed83221..bae1180 100755
+--- a/configure
++++ b/configure
+@@ -469,7 +469,7 @@ int main(void) {
+ }
+ EOF
+ if $XCC _curses.c -o _curses -lcurses 2>&3; then
+- LIB_CURSES=-lcurses
++ LIB_CURSES="-lcurses -ltinfo"
+ fi
+ rm -f _curses.c _curses
+ fi
+--
+2.24.1
+
diff --git a/net-misc/dhcpcd-ui/metadata.xml b/net-misc/dhcpcd-ui/metadata.xml
index a2e2ed249ee7..f3c463d88512 100644
--- a/net-misc/dhcpcd-ui/metadata.xml
+++ b/net-misc/dhcpcd-ui/metadata.xml
@@ -3,8 +3,11 @@
<pkgmetadata>
<!-- maintainer-needed -->
<use>
+ <flag name="gtk2">
+ Build with <pkg>x11-libs/gtk+</pkg> version 2 instead of version 3
+ </flag>
<flag name="gtk3">
- Add support for <pkg>x11-libs/gtk+</pkg> (The GIMP Toolkit)
+ Add support for <pkg>x11-libs/gtk+</pkg> version 3 (The GIMP Toolkit)
</flag>
</use>
</pkgmetadata>