summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-06-30 09:42:17 +0200
committerJeroen Roovers <jer@gentoo.org>2016-06-30 09:42:17 +0200
commit674033848f60ed6ad39ea5e421ca4a36e9b14c15 (patch)
tree1ffef060fe6e57a8814768ea67ee4a83ad0457ea /net-misc
parentdev-libs/openssl: Stable for HPPA (bug #585276). (diff)
downloadgentoo-674033848f60ed6ad39ea5e421ca4a36e9b14c15.tar.gz
gentoo-674033848f60ed6ad39ea5e421ca4a36e9b14c15.tar.bz2
gentoo-674033848f60ed6ad39ea5e421ca4a36e9b14c15.zip
net-misc/youtube-dl: Version bump.
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2016.06.27.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 67fc8cdef89f..a598acdc0621 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2016.01.01.tar.gz 1874602 SHA256 732f37c99d71b4239d72d61dd32214b5a5a618671fb0629c8f8deb28209a172c SHA512 fdb022bed426250e5ee1c2bcc1354dd195c0f9793ca479ca8ca4cfe2f71e07ba100b0dbcda2fb9f310308ab130587d06b16a6a86f9036f0d196b317d2e5b5e92 WHIRLPOOL 152e709ba15264c35a89644ea0d4793bb47c82b317e54043ccfff72e40bdf95e42d76605e801233632d3863537a945cfb9ecc2f75245171b8de31b51ce6af801
DIST youtube-dl-2016.06.23.1.tar.gz 2214493 SHA256 fd4e2304eb71c934502929446596b898ca7197b26dabb3540795bcfcc16a2e13 SHA512 342ef1304050547cbce5f057ae980b71c016a13fba06e6f9a42a2dcf29a493b3d398527a1a482013df5c7aad41e2e76981a707133214b7e3fc002dbb82e4e262 WHIRLPOOL 8b6c0e993a944e4b6ba73128bcd6ccd5d020feb8a9d7d2598be892c72a4b1dda1ae8135e7c8840e0e33a523e7987b7fa74beaea20a8f318db5d10769a8cf25ec
DIST youtube-dl-2016.06.25.tar.gz 2218218 SHA256 4b89cb8dd9314f3291509ec9fce99e25ffd2161b745e1fff064ae102bbf6a12f SHA512 ec7362d19d442fefae59df23e1b0cd5f9bafea21e3b47999f93674d2acfc7058ecae4ec15038e7cdd5d6c05f40839bbaa771b01dc5c38ad888214b5fff9497b7 WHIRLPOOL 11be7196c5f8647a61e26e401b783601beca666f53b805e652759ebe7c87f45b6eb06da58841b2aa7d5ab5bf5e4b4449fef13359f4c3ece64f6ed274aa3deea8
+DIST youtube-dl-2016.06.27.tar.gz 2224557 SHA256 6ccb3ab1b2e3d5c231b9fff3bffe7c60b3c4973a8269bbe6a5b6835527109bcf SHA512 e117e6c0cab79acc4225bbf6e4bdaa1d439ca35f6018ac49c20c48fd72a0297f703ba5885f6ce378eefa5f26ac94c080682d1012467971ab72803deca3a576f4 WHIRLPOOL b2693ecb168e0ee6d3eab36f4e7ec8e0ae0e18313c3c60fae80fa601c801a245a8559227705a2ad4b12fa6d3ab9175c5fe8806fe19037790f0ba568ac91dd87a
diff --git a/net-misc/youtube-dl/youtube-dl-2016.06.27.ebuild b/net-misc/youtube-dl/youtube-dl-2016.06.27.ebuild
new file mode 100644
index 000000000000..969c3bf49e3d
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2016.06.27.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
+DISTUTILS_SINGLE_IMPL=true
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate drtuber eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 pornhd pornotube pornovoisines pornoxo redtube
+ ruleporn sexu slutload spankbang spankwire sunporno thisav trutube
+ tube8 vporn watchindianporn xbef xnxx xtube xvideos xxxymovies
+ youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ pornhub xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ python_domodule youtube_dl
+ dobin bin/${PN}
+
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ python_fix_shebang "${ED}"
+}