summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-11-24 02:21:21 +0000
committerSam James <sam@gentoo.org>2020-11-24 02:22:16 +0000
commit6a9ad0e5536ad9df769f29e0c7e40324fcde1437 (patch)
tree635e41de496af326b6cd572d365884a8b8a78e8e /net-misc
parentmedia-libs/bcg729: disable static-libs (diff)
downloadgentoo-6a9ad0e5536ad9df769f29e0c7e40324fcde1437.tar.gz
gentoo-6a9ad0e5536ad9df769f29e0c7e40324fcde1437.tar.bz2
gentoo-6a9ad0e5536ad9df769f29e0c7e40324fcde1437.zip
net-misc/chrony: tidy ebuild
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/chrony/chrony-4.0.ebuild46
-rw-r--r--net-misc/chrony/chrony-9999.ebuild46
2 files changed, 44 insertions, 48 deletions
diff --git a/net-misc/chrony/chrony-4.0.ebuild b/net-misc/chrony/chrony-4.0.ebuild
index a13a14df678e..11c78bf628dd 100644
--- a/net-misc/chrony/chrony-4.0.ebuild
+++ b/net-misc/chrony/chrony-4.0.ebuild
@@ -2,57 +2,55 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit systemd tmpfiles toolchain-funcs
DESCRIPTION="NTP client and server programs"
HOMEPAGE="https://chrony.tuxfamily.org/"
if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="https://git.tuxfamily.org/chrony/chrony.git"
-
inherit git-r3
+ EGIT_REPO_URI="https://git.tuxfamily.org/chrony/chrony.git"
else
SRC_URI="https://download.tuxfamily.org/${PN}/${P/_/-}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
fi
+S="${WORKDIR}/${P/_/-}"
+
LICENSE="GPL-2"
SLOT="0"
-IUSE="
- +caps +cmdmon html ipv6 libedit +nettle +ntp +phc pps +refclock
- +rtc samba +seccomp +sechash selinux
-"
-REQUIRED_USE="
- sechash? ( nettle )
-"
-RESTRICT=test
-CDEPEND="
- caps? ( acct-group/ntp acct-user/ntp sys-libs/libcap )
+IUSE="+caps +cmdmon html ipv6 libedit +nettle +ntp +phc pps +refclock +rtc samba +seccomp +sechash selinux"
+REQUIRED_USE="sechash? ( nettle )"
+RESTRICT="test"
+
+BDEPEND="nettle? ( virtual/pkgconfig )"
+
+if [[ ${PV} == "9999" ]]; then
+ BDEPEND+=" virtual/w3m"
+fi
+
+DEPEND="
+ caps? (
+ acct-group/ntp
+ acct-user/ntp
+ sys-libs/libcap
+ )
libedit? ( dev-libs/libedit )
nettle? ( dev-libs/nettle:= )
seccomp? ( sys-libs/libseccomp )
-"
-DEPEND="
- ${CDEPEND}
html? ( dev-ruby/asciidoctor )
pps? ( net-misc/pps-tools )
"
RDEPEND="
- ${CDEPEND}
+ ${DEPEND}
selinux? ( sec-policy/selinux-chronyd )
"
-BDEPEND="
- nettle? ( virtual/pkgconfig )
-"
+
PATCHES=(
"${FILESDIR}"/${PN}-3.5-pool-vendor-gentoo.patch
"${FILESDIR}"/${PN}-3.5-r3-systemd-gentoo.patch
)
-S="${WORKDIR}/${P/_/-}"
-
-if [[ ${PV} == "9999" ]]; then
- BDEPEND+=" virtual/w3m"
-fi
src_prepare() {
default
diff --git a/net-misc/chrony/chrony-9999.ebuild b/net-misc/chrony/chrony-9999.ebuild
index a13a14df678e..11c78bf628dd 100644
--- a/net-misc/chrony/chrony-9999.ebuild
+++ b/net-misc/chrony/chrony-9999.ebuild
@@ -2,57 +2,55 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit systemd tmpfiles toolchain-funcs
DESCRIPTION="NTP client and server programs"
HOMEPAGE="https://chrony.tuxfamily.org/"
if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="https://git.tuxfamily.org/chrony/chrony.git"
-
inherit git-r3
+ EGIT_REPO_URI="https://git.tuxfamily.org/chrony/chrony.git"
else
SRC_URI="https://download.tuxfamily.org/${PN}/${P/_/-}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
fi
+S="${WORKDIR}/${P/_/-}"
+
LICENSE="GPL-2"
SLOT="0"
-IUSE="
- +caps +cmdmon html ipv6 libedit +nettle +ntp +phc pps +refclock
- +rtc samba +seccomp +sechash selinux
-"
-REQUIRED_USE="
- sechash? ( nettle )
-"
-RESTRICT=test
-CDEPEND="
- caps? ( acct-group/ntp acct-user/ntp sys-libs/libcap )
+IUSE="+caps +cmdmon html ipv6 libedit +nettle +ntp +phc pps +refclock +rtc samba +seccomp +sechash selinux"
+REQUIRED_USE="sechash? ( nettle )"
+RESTRICT="test"
+
+BDEPEND="nettle? ( virtual/pkgconfig )"
+
+if [[ ${PV} == "9999" ]]; then
+ BDEPEND+=" virtual/w3m"
+fi
+
+DEPEND="
+ caps? (
+ acct-group/ntp
+ acct-user/ntp
+ sys-libs/libcap
+ )
libedit? ( dev-libs/libedit )
nettle? ( dev-libs/nettle:= )
seccomp? ( sys-libs/libseccomp )
-"
-DEPEND="
- ${CDEPEND}
html? ( dev-ruby/asciidoctor )
pps? ( net-misc/pps-tools )
"
RDEPEND="
- ${CDEPEND}
+ ${DEPEND}
selinux? ( sec-policy/selinux-chronyd )
"
-BDEPEND="
- nettle? ( virtual/pkgconfig )
-"
+
PATCHES=(
"${FILESDIR}"/${PN}-3.5-pool-vendor-gentoo.patch
"${FILESDIR}"/${PN}-3.5-r3-systemd-gentoo.patch
)
-S="${WORKDIR}/${P/_/-}"
-
-if [[ ${PV} == "9999" ]]; then
- BDEPEND+=" virtual/w3m"
-fi
src_prepare() {
default