summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-10-22 22:03:15 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-10-26 23:13:50 +0200
commit71ce2735e5823c0f59653480a0c0a5f6fca60b4b (patch)
tree2fcb89680ce37f7df48717258bb91779a8bb9bd7 /net-misc
parentdev-libs/libcec: various fixes. (diff)
downloadgentoo-71ce2735e5823c0f59653480a0c0a5f6fca60b4b.tar.gz
gentoo-71ce2735e5823c0f59653480a0c0a5f6fca60b4b.tar.bz2
gentoo-71ce2735e5823c0f59653480a0c0a5f6fca60b4b.zip
net-misc/owncloud-client: drop USE=qt4.
Drop unnecessary REQUIRED_USE, simplify ebuild. Package-Manager: portage-2.3.0 Acked-By: David Seifert <soap@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/2638 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/owncloud-client/owncloud-client-2.2.4-r1.ebuild91
1 files changed, 91 insertions, 0 deletions
diff --git a/net-misc/owncloud-client/owncloud-client-2.2.4-r1.ebuild b/net-misc/owncloud-client/owncloud-client-2.2.4-r1.ebuild
new file mode 100644
index 000000000000..13fa7f634616
--- /dev/null
+++ b/net-misc/owncloud-client/owncloud-client-2.2.4-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Synchronize files from ownCloud Server with your computer"
+HOMEPAGE="http://owncloud.org/"
+SRC_URI="http://download.owncloud.com/desktop/stable/${P/-}.tar.xz"
+
+LICENSE="CC-BY-3.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc dolphin nautilus samba +sftp test"
+
+COMMON_DEPEND=">=dev-db/sqlite-3.4:3
+ dev-libs/qtkeychain[qt5]
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtsql:5
+ dev-qt/qtwebkit:5[printsupport]
+ sys-fs/inotify-tools
+ virtual/libiconv
+ dolphin? (
+ kde-frameworks/kcoreaddons:5
+ kde-frameworks/kio:5
+ )
+ nautilus? ( dev-python/nautilus-python )
+ samba? ( >=net-fs/samba-3.5 )
+ sftp? ( >=net-libs/libssh-0.5 )
+"
+RDEPEND="${COMMON_DEPEND}
+ !net-misc/ocsync
+ !net-misc/nextcloud-client
+"
+DEPEND="${COMMON_DEPEND}
+ dev-qt/linguist-tools:5
+ doc? (
+ dev-python/sphinx
+ dev-texlive/texlive-latexextra
+ virtual/latex-base
+ )
+ dolphin? ( kde-frameworks/extra-cmake-modules )
+ test? (
+ dev-util/cmocka
+ dev-qt/qttest:5
+ )
+"
+
+S=${WORKDIR}/${P/-}
+
+src_prepare() {
+ # Keep tests in ${T}
+ sed -i -e "s#\"/tmp#\"${T}#g" test/test*.cpp || die "sed failed"
+
+ if ! use nautilus; then
+ pushd shell_integration > /dev/null || die
+ cmake_comment_add_subdirectory nautilus
+ popd > /dev/null || die
+ fi
+ default
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc
+ -DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF}
+ -DWITH_ICONV=ON
+ -DWITH_DOC=$(usex doc)
+ -DCMAKE_DISABLE_FIND_PACKAGE_KF5=$(usex !dolphin)
+ -DBUILD_WITH_QT4=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libsmbclient=$(usex !samba)
+ -DCMAKE_DISABLE_FIND_PACKAGE_LibSSH=$(usex !sftp)
+ -DUNIT_TESTING=$(usex test)
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ if ! use doc ; then
+ elog "Documentation and man pages not installed"
+ elog "Enable doc USE-flag to generate them"
+ fi
+}