summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2022-01-23 16:33:46 +0100
committerSam James <sam@gentoo.org>2022-01-28 07:59:20 +0000
commit79a2cc81a7b379ba46fe670b8371bee29f648a73 (patch)
tree4c53f46910224a2bf1c22acf71e3475a1765d7d9 /net-misc
parentnet-misc/s6-networking: drop 2.3.0.2, 2.3.0.3, 2.3.0.4, 2.3.1.1 (diff)
downloadgentoo-79a2cc81a7b379ba46fe670b8371bee29f648a73.tar.gz
gentoo-79a2cc81a7b379ba46fe670b8371bee29f648a73.tar.bz2
gentoo-79a2cc81a7b379ba46fe670b8371bee29f648a73.zip
net-misc/s6-networking: respect AR, CC and RANLIB
Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/s6-networking/s6-networking-2.3.2.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/net-misc/s6-networking/s6-networking-2.3.2.0.ebuild b/net-misc/s6-networking/s6-networking-2.3.2.0.ebuild
index 356302cf9f86..188831293ff0 100644
--- a/net-misc/s6-networking/s6-networking-2.3.2.0.ebuild
+++ b/net-misc/s6-networking/s6-networking-2.3.2.0.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="Suite of small networking utilities for Unix systems"
HOMEPAGE="https://www.skarnet.org/software/s6-networking/"
SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
@@ -33,9 +35,13 @@ src_prepare() {
# Avoid QA warning for LDFLAGS addition; avoid overriding -fstack-protector
sed -i -e 's/.*-Wl,--hash-style=both$/:/' -e '/-fno-stack-protector$/d' \
configure || die
+
+ sed -i -e '/AR := /d' -e '/RANLIB := /d' Makefile || die
}
src_configure() {
+ tc-export AR CC RANLIB
+
econf \
--bindir=/bin \
--dynlibdir=/usr/$(get_libdir) \