summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen L Arnold <nerdboy@gentoo.org>2018-02-26 23:13:34 -0800
committerStephen L Arnold <nerdboy@gentoo.org>2018-02-26 23:13:34 -0800
commit8b1d82cd97939eca1f801304c9a516533b1b9a9f (patch)
treeb4ae65d9b29de28fd250fe0a3e712e6922b584c3 /net-misc
parentpackage.mask: unmask postfix-3.3 releases (diff)
downloadgentoo-8b1d82cd97939eca1f801304c9a516533b1b9a9f.tar.gz
gentoo-8b1d82cd97939eca1f801304c9a516533b1b9a9f.tar.bz2
gentoo-8b1d82cd97939eca1f801304c9a516533b1b9a9f.zip
net-misc/ntpsec: fix debug flag in git ebuild and add einfo refclocks
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/ntpsec/ntpsec-1.0.0-r4.ebuild9
-rw-r--r--net-misc/ntpsec/ntpsec-9999.ebuild17
2 files changed, 24 insertions, 2 deletions
diff --git a/net-misc/ntpsec/ntpsec-1.0.0-r4.ebuild b/net-misc/ntpsec/ntpsec-1.0.0-r4.ebuild
index e0b19c3eb0d8..3d627137b639 100644
--- a/net-misc/ntpsec/ntpsec-1.0.0-r4.ebuild
+++ b/net-misc/ntpsec/ntpsec-1.0.0-r4.ebuild
@@ -143,3 +143,12 @@ src_install() {
cp -v "${FILESDIR}"/ntp.conf "${ED}"/etc/ntp.conf
cp -Rv "${S}"/etc/ntp.d/ "${ED}"/etc/
}
+
+pkg_postinst() {
+ einfo "If you want to serve time on your local network, then"
+ einfo "you should disable all the ref_clocks unless you have"
+ einfo "one and can get stable time from it. Feel free to try"
+ einfo "it but PPS probably won't work unless you have a UART"
+ einfo "GPS that actually provides PPS messages."
+}
+
diff --git a/net-misc/ntpsec/ntpsec-9999.ebuild b/net-misc/ntpsec/ntpsec-9999.ebuild
index a565abf1c84d..6b202f936056 100644
--- a/net-misc/ntpsec/ntpsec-9999.ebuild
+++ b/net-misc/ntpsec/ntpsec-9999.ebuild
@@ -32,7 +32,7 @@ IUSE_NTPSEC_REFCLOCK=${NTPSEC_REFCLOCK[@]/#/rclock_}
LICENSE="HPND MIT BSD-2 BSD CC-BY-SA-4.0"
SLOT="0"
-IUSE="${IUSE_NTPSEC_REFCLOCK} doc early gdb heat libressl nist ntpviz samba seccomp smear tests" #ionice
+IUSE="${IUSE_NTPSEC_REFCLOCK} debug doc early gdb heat libressl nist ntpviz samba seccomp smear tests" #ionice
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
# net-misc/pps-tools oncore,pps
@@ -57,6 +57,8 @@ DEPEND="${CDEPEND}
!net-misc/openntpd
"
+WAF_BINARY="${S}/waf"
+
pkg_setup() {
enewgroup ntp 123
enewuser ntp 123 -1 /dev/null ntp
@@ -95,7 +97,9 @@ src_configure() {
$(use samba && echo "--enable-mssntp")
$(use seccomp && echo "--enable-seccomp")
$(use smear && echo "--enable-leap-smear")
- $(use tests && echo "--alltests"))
+ $(use tests && echo "--alltests")
+ $(use debug && echo "--enable-debug")
+ )
python_configure() {
waf-utils_src_configure "${myconf[@]}"
@@ -104,6 +108,7 @@ src_configure() {
}
src_compile() {
+ unset MAKEOPTS
python_compile() {
waf-utils_src_compile
}
@@ -139,3 +144,11 @@ src_install() {
cp -v "${FILESDIR}"/ntp.conf "${ED}"/etc/ntp.conf
cp -Rv "${S}"/etc/ntp.d/ "${ED}"/etc/
}
+
+pkg_postinst() {
+ einfo "If you want to serve time on your local network, then"
+ einfo "you should disable all the ref_clocks unless you have"
+ einfo "one and can get stable time from it. Feel free to try"
+ einfo "it but PPS probably won't work unless you have a UART"
+ einfo "GPS that actually provides PPS messages."
+}