summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-01-03 19:37:47 +0100
committerDavid Seifert <soap@gentoo.org>2018-01-03 19:37:47 +0100
commit91a00775903ca1bb19aca687dc2234cd33a046f6 (patch)
tree88a6c357b09b5046818b1ad168d4242759c8c596 /net-misc
parentnet-misc/netkit-bootpd: Port to EAPI 6 (diff)
downloadgentoo-91a00775903ca1bb19aca687dc2234cd33a046f6.tar.gz
gentoo-91a00775903ca1bb19aca687dc2234cd33a046f6.tar.bz2
gentoo-91a00775903ca1bb19aca687dc2234cd33a046f6.zip
net-misc/openr2: Port to EAPI 6
Closes: https://bugs.gentoo.org/543402 Closes: https://bugs.gentoo.org/581018 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/openr2/files/1.3.0-respect-user-cflags.patch15
-rw-r--r--net-misc/openr2/files/openr2-1.3.0-fix-build-system.patch30
-rw-r--r--net-misc/openr2/openr2-1.3.0.ebuild21
3 files changed, 45 insertions, 21 deletions
diff --git a/net-misc/openr2/files/1.3.0-respect-user-cflags.patch b/net-misc/openr2/files/1.3.0-respect-user-cflags.patch
deleted file mode 100644
index 7a8f23f3f29c..000000000000
--- a/net-misc/openr2/files/1.3.0-respect-user-cflags.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -uNr openr2-1.3.0.ORIG//configure.in openr2-1.3.0/configure.in
---- openr2-1.3.0.ORIG//configure.in 2010-05-13 11:59:14.000000000 +0100
-+++ openr2-1.3.0/configure.in 2010-05-13 11:59:35.000000000 +0100
-@@ -25,11 +25,6 @@
- AC_CONFIG_HEADERS(config.h)
- AM_INIT_AUTOMAKE
-
--# let's default to compile with debugging information
--# most users will not even care about it
--CFLAGS='-ggdb3 -O0'
--CXXFLAGS='-ggdb3 -O0'
--
- AC_PROG_CC
- AC_PROG_LIBTOOL
- AC_LANG([C])
diff --git a/net-misc/openr2/files/openr2-1.3.0-fix-build-system.patch b/net-misc/openr2/files/openr2-1.3.0-fix-build-system.patch
new file mode 100644
index 000000000000..59918934d563
--- /dev/null
+++ b/net-misc/openr2/files/openr2-1.3.0-fix-build-system.patch
@@ -0,0 +1,30 @@
+--- a/configure.in
++++ b/configure.in
+@@ -25,11 +25,6 @@
+ AC_CONFIG_HEADERS(config.h)
+ AM_INIT_AUTOMAKE
+
+-# let's default to compile with debugging information
+-# most users will not even care about it
+-CFLAGS='-ggdb3 -O0'
+-CXXFLAGS='-ggdb3 -O0'
+-
+ AC_PROG_CC
+ AC_PROG_LIBTOOL
+ AC_LANG([C])
+diff -ur ORIG/src/Makefile.am MOD/src/Makefile.am
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -1,10 +1,10 @@
+-AM_CFLAGS = -std=c99 -pedantic -Wall -Werror -Wwrite-strings -Wunused-variable -Wstrict-prototypes -Wmissing-prototypes
++AM_CFLAGS = -std=c99 -pedantic -Werror -Wwrite-strings -Wunused-variable -Wstrict-prototypes -Wmissing-prototypes
+ if WANT_OR2_TRACE_STACKS
+ AM_CFLAGS += -DOR2_TRACE_STACKS
+ endif
+
+ if HAVE_SVNVERSION
+-AM_CFLAGS += -DREVISION=\"$(shell svnversion -n .)\"
++AM_CFLAGS += -DREVISION=\"0\"
+ endif
+
+ lib_LTLIBRARIES = libopenr2.la
diff --git a/net-misc/openr2/openr2-1.3.0.ebuild b/net-misc/openr2/openr2-1.3.0.ebuild
index d00d14389463..3e45c4921241 100644
--- a/net-misc/openr2/openr2-1.3.0.ebuild
+++ b/net-misc/openr2/openr2-1.3.0.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=3
-inherit autotools base
+EAPI=6
+
+inherit autotools
DESCRIPTION="An open implementation of the MFC/R2 telephony signaling protocol"
HOMEPAGE="http://libopenr2.org/"
@@ -14,13 +15,21 @@ KEYWORDS="~amd64"
IUSE=""
RDEPEND="net-misc/dahdi"
-PATCHES=( "${FILESDIR}/${PV}-respect-user-cflags.patch" )
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-fix-build-system.patch )
src_prepare() {
- base_src_prepare
+ default
+ mv configure.{in,ac} || die
eautoreconf
}
+src_configure() {
+ econf --disable-static
+}
+
src_install() {
- emake DESTDIR="${D}" install || die
+ default
+ find "${D}" -name '*.la' -delete || die
}