summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2017-01-04 20:54:18 +0100
committerJason A. Donenfeld <zx2c4@gentoo.org>2017-01-04 20:54:39 +0100
commit99cbbc98972f3c40906ee84556b30c43c26643fd (patch)
tree19e97fc2f2a23a98d06316c75b1bfde8e15ae2fe /net-misc
parentmail-client/mutt: revbump 1.7.2 for latest features/fixes from upstream (diff)
downloadgentoo-99cbbc98972f3c40906ee84556b30c43c26643fd.tar.gz
gentoo-99cbbc98972f3c40906ee84556b30c43c26643fd.tar.bz2
gentoo-99cbbc98972f3c40906ee84556b30c43c26643fd.zip
net-misc/wireguard: support improved tooling
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/wireguard/wireguard-9999.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/net-misc/wireguard/wireguard-9999.ebuild b/net-misc/wireguard/wireguard-9999.ebuild
index 0aa291de13d6..db54269b3592 100644
--- a/net-misc/wireguard/wireguard-9999.ebuild
+++ b/net-misc/wireguard/wireguard-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
-inherit linux-mod
+inherit linux-mod bash-completion-r1
DESCRIPTION="Simple yet fast and modern VPN that utilizes state-of-the-art cryptography."
HOMEPAGE="https://www.wireguard.io/"
@@ -48,8 +48,14 @@ src_compile() {
src_install() {
dodoc README.md
dodoc -r contrib/examples
- emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" -C src/tools install
- emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" -C contrib/examples/wg-config install
+ emake \
+ WITH_BASHCOMPLETION=yes \
+ WITH_SYSTEMDUNITS=yes \
+ WITH_WGQUICK=yes \
+ DESTDIR="${D}" \
+ BASHCOMPDIR="$(get_bashcompdir)" \
+ PREFIX="${EPREFIX}/usr" \
+ -C src/tools install
if use kmod-src; then
emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" -C src dkms-install
else