summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-09-01 11:03:06 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-09-01 11:40:04 +0200
commit9c57a621d82e8dd310cdd5043f302b25e6d41abc (patch)
treeca900e4086b28d5795025734b56458480ef78c9c /net-misc
parentapp-vim/bnf-syntax: Clean up old. (diff)
downloadgentoo-9c57a621d82e8dd310cdd5043f302b25e6d41abc.tar.gz
gentoo-9c57a621d82e8dd310cdd5043f302b25e6d41abc.tar.bz2
gentoo-9c57a621d82e8dd310cdd5043f302b25e6d41abc.zip
net-misc/spiped: EAPI 6 bump.
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/spiped/spiped-1.5.0-r2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-misc/spiped/spiped-1.5.0-r2.ebuild b/net-misc/spiped/spiped-1.5.0-r2.ebuild
new file mode 100644
index 000000000000..3dcc387ab2ca
--- /dev/null
+++ b/net-misc/spiped/spiped-1.5.0-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="secure pipe daemon"
+HOMEPAGE="http://www.tarsnap.com/spiped.html"
+SRC_URI="http://www.tarsnap.com/${PN}/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+MY_PN="${PN/d/}"
+
+DEPEND="
+ dev-libs/openssl:*"
+
+# Blocker added due to #548126
+RDEPEND="
+ ${DEPEND}
+ !net-mail/qlogtools"
+
+src_install() {
+ dobin "${MY_PN}/${MY_PN}"
+ dosbin "${PN}/${PN}"
+
+ doman "${MY_PN}/${MY_PN}.1" "${PN}/${PN}.1"
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+
+ dodir "etc/${PN}"
+}
+
+pkg_postinst() {
+ elog
+ elog "You will need to configure spiped via its"
+ elog "configuration file located in /etc/conf.d/."
+ elog
+ elog "Please have a look at this file prior to starting up spiped!"
+ elog
+}