summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2018-11-12 01:51:07 +0000
committerYixun Lan <dlan@gentoo.org>2018-11-12 01:56:06 +0000
commit9d4c87d33fd9ddb918e0417d85016df08656e73f (patch)
tree835ee8356a7a15c1e50e7e004e6ee7b81138aa86 /net-misc
parentapp-emulation/xen-tools: x86 stable (bug #670858) (diff)
downloadgentoo-9d4c87d33fd9ddb918e0417d85016df08656e73f.tar.gz
gentoo-9d4c87d33fd9ddb918e0417d85016df08656e73f.tar.bz2
gentoo-9d4c87d33fd9ddb918e0417d85016df08656e73f.zip
net-misc/megatools: fix build warning
fix unrecognized configure options issue, bump EAPI=7 Closes: https://bugs.gentoo.org/668698 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/megatools/megatools-1.10.2-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/megatools/megatools-1.10.2-r1.ebuild b/net-misc/megatools/megatools-1.10.2-r1.ebuild
new file mode 100644
index 000000000000..1d9b22e67f63
--- /dev/null
+++ b/net-misc/megatools/megatools-1.10.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools eutils
+
+DESCRIPTION="Command line tools and C library for accessing Mega cloud storage"
+HOMEPAGE="https://github.com/megous/megatools"
+SRC_URI="https://github.com/megous/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+COMMON_DEPEND="dev-libs/glib:2
+ dev-libs/openssl:0=
+ net-misc/curl
+"
+RDEPEND="${COMMON_DEPEND}
+ net-libs/glib-networking[ssl]
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ app-text/asciidoc"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ default
+ econf \
+ --disable-maintainer-mode \
+ --disable-warnings
+
+}