summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2021-03-07 17:29:13 +0100
committerDennis Lamm <expeditioneer@gentoo.org>2021-03-08 07:16:12 +0100
commitaa82a52d9a4facf1851dcfef556afece28c039e5 (patch)
tree32b49277c5903f91d0610ec0d419b4f78447d613 /net-misc
parentapp-emulation/spice-protocol: version bump to 0.14.3 (diff)
downloadgentoo-aa82a52d9a4facf1851dcfef556afece28c039e5.tar.gz
gentoo-aa82a52d9a4facf1851dcfef556afece28c039e5.tar.bz2
gentoo-aa82a52d9a4facf1851dcfef556afece28c039e5.zip
net-misc/spice-gtk: version bump to 0.39
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org> Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/spice-gtk/Manifest1
-rw-r--r--net-misc/spice-gtk/spice-gtk-0.39.ebuild123
2 files changed, 124 insertions, 0 deletions
diff --git a/net-misc/spice-gtk/Manifest b/net-misc/spice-gtk/Manifest
index 8566ca0ef558..4be76f585699 100644
--- a/net-misc/spice-gtk/Manifest
+++ b/net-misc/spice-gtk/Manifest
@@ -1,2 +1,3 @@
DIST spice-gtk-0.37.tar.bz2 1303111 BLAKE2B cf4b6664ac86d126cf14f1a31b1df93079e15fc0a0af69bfaf61cb84284daa7b6b8cb2a2ee3345f6a475838ffc0fb2a2b0bdd61301e2c1479fb5f5e0c28babbe SHA512 a0a20bc6f25337d86e57fe1fc9586c4cc84457fc8c38cdcc5a728990a69018da0fca3ab5aa63349786b5a7508c82b716c94803eefb3495cffb7df4526db2d029
DIST spice-gtk-0.38.tar.xz 796112 BLAKE2B c1542b5b76f9e23ffd1910273f358f656198829b1f615c6a8e0931a79d14920132c861facd534f4cf05f03c4f64a50f628f7daa93be581d5ac815f224b81fe16 SHA512 27b44ac9f0cee2737ce03bb3f47c62fc0ee2402c291c49fc56cffc4ccb63e2cab001a68ba865a6375d82cb38444408d59c68469783ee4279fa818d8682e902f3
+DIST spice-gtk-0.39.tar.xz 845528 BLAKE2B c886c4c9f0e51d7f2bf6dbfe574f1a2bcab249f863cb7da1f009410572cdaa7a35ef98fc370a7e74f7e490ad3bfe8ffa832601f8bb0b0894b90ec1de76495ce9 SHA512 ff0f3ca6b10a2c415f2fa8d61464c5710aaa2a46c2c83909f146fa45f01151e756d9c3d79cb162dd3d0c1279b6ef55a67fc5c1266af2cb5b46ac1eaa0254c8d2
diff --git a/net-misc/spice-gtk/spice-gtk-0.39.ebuild b/net-misc/spice-gtk/spice-gtk-0.39.ebuild
new file mode 100644
index 000000000000..8f9a666c3e7f
--- /dev/null
+++ b/net-misc/spice-gtk/spice-gtk-0.39.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VALA_MIN_API_VERSION="0.14"
+VALA_USE_DEPEND="vapigen"
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit desktop eutils meson python-any-r1 readme.gentoo-r1 vala xdg-utils
+
+DESCRIPTION="Set of GObject and Gtk objects for connecting to Spice servers and a client GUI"
+HOMEPAGE="https://www.spice-space.org https://cgit.freedesktop.org/spice/spice-gtk/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+SRC_URI="https://www.spice-space.org/download/gtk/${P}.tar.xz"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+gtk3 +introspection libressl lz4 mjpeg policykit sasl smartcard usbredir vala wayland webdav"
+
+# TODO:
+# * check if sys-freebsd/freebsd-lib (from virtual/acl) provides acl/libacl.h
+# * use external pnp.ids as soon as that means not pulling in gnome-desktop
+RDEPEND="
+ >=dev-libs/glib-2.46:2
+ dev-libs/json-glib:0=
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0
+ media-libs/gstreamer:1.0[introspection?]
+ media-libs/opus
+ sys-libs/zlib
+ virtual/jpeg:0=
+ >=x11-libs/cairo-1.2
+ >=x11-libs/pixman-0.17.7
+ gtk3? ( x11-libs/gtk+:3[introspection?] )
+ introspection? ( dev-libs/gobject-introspection )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ lz4? ( app-arch/lz4 )
+ sasl? ( dev-libs/cyrus-sasl )
+ smartcard? ( app-emulation/qemu[smartcard] )
+ usbredir? (
+ sys-apps/hwids
+ >=sys-apps/usbredir-0.4.2
+ virtual/libusb:1
+ policykit? (
+ sys-apps/acl
+ >=sys-auth/polkit-0.110-r1
+ )
+ )
+ webdav? (
+ net-libs/phodav:2.0
+ >=net-libs/libsoup-2.49.91 )
+"
+# TODO: spice-gtk has an automagic dependency on x11-libs/libva without a
+# configure knob. The package is relatively lightweight so we just depend
+# on it unconditionally for now. It would be cleaner to transform this into
+# a USE="vaapi" conditional and patch the buildsystem...
+RDEPEND="${RDEPEND}
+ amd64? ( x11-libs/libva:= )
+ arm64? ( x11-libs/libva:= )
+ x86? ( x11-libs/libva:= )
+"
+DEPEND="${RDEPEND}
+ >=app-emulation/spice-protocol-0.14.3
+ dev-perl/Text-CSV
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.40.0
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+BDEPEND="
+ $(python_gen_any_dep '
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ ')
+"
+
+python_check_deps() {
+ has_version "dev-python/six[${PYTHON_USEDEP}]" &&
+ has_version "dev-python/pyparsing[${PYTHON_USEDEP}]"
+}
+
+src_prepare() {
+ default
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature gtk3 gtk)
+ $(meson_feature introspection)
+ $(meson_use mjpeg builtin-mjpeg)
+ $(meson_feature policykit polkit)
+ $(meson_feature lz4)
+ $(meson_feature sasl)
+ $(meson_feature smartcard)
+ $(meson_feature usbredir)
+ $(meson_feature vala vapi)
+ $(meson_feature webdav)
+ $(meson_feature wayland wayland-protocols)
+ )
+
+ if use usbredir; then
+ emesonargs+=(
+ -Dusb-acl-helper-dir=/usr/libexec
+ -Dusb-ids-path=/usr/share/misc/usb.ids
+ )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ make_desktop_entry spicy Spicy "utilities-terminal" "Network;RemoteAccess;"
+ readme.gentoo_create_doc
+}