summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-11 17:05:09 +0000
committerSam James <sam@gentoo.org>2021-03-11 17:05:59 +0000
commitae84430430dfbc777f52698a109b16cd6902cae2 (patch)
treea0e0822fb651311fb9aea7ed295cf48d24ca379b /net-misc
parentnet-misc/netpipes: EAPI7 bump (diff)
downloadgentoo-ae84430430dfbc777f52698a109b16cd6902cae2.tar.gz
gentoo-ae84430430dfbc777f52698a109b16cd6902cae2.tar.bz2
gentoo-ae84430430dfbc777f52698a109b16cd6902cae2.zip
net-misc/netpipes: minor style changes, change sed delimiter
* Minor style changes * Adjust sed delimiter to ; to avoid colon-in-CFLAGS issues Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/netpipes/netpipes-4.2-r2.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/net-misc/netpipes/netpipes-4.2-r2.ebuild b/net-misc/netpipes/netpipes-4.2-r2.ebuild
index d49bf549fc19..ed14038c1dc8 100644
--- a/net-misc/netpipes/netpipes-4.2-r2.ebuild
+++ b/net-misc/netpipes/netpipes-4.2-r2.ebuild
@@ -8,28 +8,29 @@ inherit toolchain-funcs
DESCRIPTION="Tools to manipulate BSD TCP/IP stream sockets"
HOMEPAGE="http://web.purplefrog.com/~thoth/netpipes/netpipes.html"
SRC_URI="http://web.purplefrog.com/~thoth/netpipes/ftp/${P}-export.tar.gz"
-LICENSE="GPL-2+"
+S="${WORKDIR}/${P}-export"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 x86"
-S="${WORKDIR}/${P}-export"
-
-PATCHES=( "${FILESDIR}/${P}"-string.patch )
+PATCHES=(
+ "${FILESDIR}/${P}"-string.patch
+)
src_prepare() {
default
sed -i \
- -e 's:CFLAGS =:CFLAGS +=:' \
- -e '/ -o /s:${CFLAGS}:$(CFLAGS) $(LDFLAGS):g' \
+ -e 's;CFLAGS =;CFLAGS +=;' \
+ -e '/ -o /s;${CFLAGS};$(CFLAGS) $(LDFLAGS);g' \
Makefile || die
}
src_compile() {
- emake CC=$(tc-getCC)
+ emake CC="$(tc-getCC)"
}
src_install() {
dodir /usr/share/man
- emake INSTROOT="${D}"/usr INSTMAN="${D}"/usr/share/man install
+ emake INSTROOT="${ED}"/usr INSTMAN="${ED}"/usr/share/man install
}