summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2021-02-25 01:27:40 +0000
committerSam James <sam@gentoo.org>2021-02-25 01:27:40 +0000
commitaf7f9e4e6383822de9d5b9c4f462041927cfc83f (patch)
tree38c4f03ed90392797d1bc0a8cffffa10e8928363 /net-misc
parentdev-python/setproctitle: Stabilize 1.2.2 sparc, #772536 (diff)
downloadgentoo-af7f9e4e6383822de9d5b9c4f462041927cfc83f.tar.gz
gentoo-af7f9e4e6383822de9d5b9c4f462041927cfc83f.tar.bz2
gentoo-af7f9e4e6383822de9d5b9c4f462041927cfc83f.zip
net-misc/dhcp: fix 32-bit build with libatomic (ppc, arm, ...)
Bug: https://bugs.gentoo.org/720806 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/dhcp/dhcp-4.4.2-r3.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/net-misc/dhcp/dhcp-4.4.2-r3.ebuild b/net-misc/dhcp/dhcp-4.4.2-r3.ebuild
index b123e346e37a..0aef829c93b2 100644
--- a/net-misc/dhcp/dhcp-4.4.2-r3.ebuild
+++ b/net-misc/dhcp/dhcp-4.4.2-r3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit systemd toolchain-funcs
+inherit systemd toolchain-funcs flag-o-matic
MY_PV="${PV//_alpha/a}"
MY_PV="${MY_PV//_beta/b}"
@@ -162,6 +162,11 @@ src_configure() {
#define _PATH_DHCRELAY6_PID "${r}/dhcrelay6.pid"
EOF
+ # https://bugs.gentoo.org/720806
+ if use ppc || use arm || use hppa; then
+ append-libs -latomic
+ fi
+
local myeconfargs=(
--enable-paranoia
--enable-early-chroot
@@ -170,6 +175,7 @@ src_configure() {
$(use_enable ipv6 dhcpv6)
$(use_with ldap)
$(use ldap && use_with ssl ldapcrypto || echo --without-ldapcrypto)
+ LIBS="${LIBS}"
)
econf "${myeconfargs[@]}"