summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarry Smallbones <info@harrysmallbones.co.uk>2020-11-01 15:47:48 +0000
committerJoonas Niilola <juippis@gentoo.org>2020-11-05 10:10:15 +0200
commitbcc99a41c97bdbfa3ab86edb67d7dc39ff552e46 (patch)
tree767eae6cc11bbe679d160396ba96e18c475f8ed2 /net-misc
parentpackage.mask: masking www-apps/webmcp waiting for lua (diff)
downloadgentoo-bcc99a41c97bdbfa3ab86edb67d7dc39ff552e46.tar.gz
gentoo-bcc99a41c97bdbfa3ab86edb67d7dc39ff552e46.tar.bz2
gentoo-bcc99a41c97bdbfa3ab86edb67d7dc39ff552e46.zip
net-misc/batctl: Version bump to 2020.4
Closes: https://bugs.gentoo.org/752114 Signed-off-by: Harry Smallbones <info@harrysmallbones.co.uk> Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/batctl/Manifest1
-rw-r--r--net-misc/batctl/batctl-2020.4.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/batctl/Manifest b/net-misc/batctl/Manifest
index 4ceaf9a89352..15a20911d49f 100644
--- a/net-misc/batctl/Manifest
+++ b/net-misc/batctl/Manifest
@@ -1,2 +1,3 @@
DIST batctl-2020.2.tar.gz 112155 BLAKE2B 9d36baf4f728163b12d63bf2b690b75633119ebc22a734668aaaae97d9c0a37ac1906dec40f62987d7c9db2ca6b0c7867164c989f3f3f5834bbc5c562b842852 SHA512 4990eece371320107cd522f5dc6ff4ecd2867d8b77ddb8a09b8c8fc81c6cf2a88df6635f026b16a2c59fc05532a82ecafae206fb1581ac7e1f863043eb3afa93
DIST batctl-2020.3.tar.gz 112394 BLAKE2B 07774836244120bde930afd6cebc20712e7a59571d19a6ea67a88a17e0779df51d221742cbbbee5c1ee086c7b75e8d5452534c971f0f08f081dd2d7f607764bb SHA512 fc93d4951e2aff91b9a5dd6c7f815bf1faaa08e861ab0116091fa796eaf95ba1b636fb057642b7ae7cef57832841d2a3ab8cdb2675ed372a303f8f5e16430395
+DIST batctl-2020.4.tar.gz 112430 BLAKE2B 3fde106d7c422ed8bf8b259fc4cf95e0732a893eb06eb99da961c2d5664079a3611eac42491855288b42b94de75b642ea515024c309ec2d3d885ebeba828ec3e SHA512 ecb7c83883b7ae2a4cebbb4319ad7f6c2138d68b91cd24b9753b54e8b0c83080e1358dc61a6bd45d03cc64132bc4f2516b3fab422f71a1e63f53a0e2187fd7e8
diff --git a/net-misc/batctl/batctl-2020.4.ebuild b/net-misc/batctl/batctl-2020.4.ebuild
new file mode 100644
index 000000000000..52be9621f8af
--- /dev/null
+++ b/net-misc/batctl/batctl-2020.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="BATMAN advanced control and management tool"
+HOMEPAGE="https://www.open-mesh.org/"
+SRC_URI="https://downloads.open-mesh.org/batman/releases/batman-adv-${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 MIT ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="dev-libs/libnl:3"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if ! linux_config_exists || ! linux_chkconfig_present BATMAN_ADV; then
+ ewarn "batctl requires batman-adv kernel support"
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" V=1 REVISION="gentoo-${PVR}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ dodoc README.rst
+}