summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-06-29 00:07:03 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-06-29 00:17:34 -0400
commitc51a2927d2e9bcf2803771e32a95aac22a0f3a3b (patch)
treeb204797c71c72fb6f4e75d66f39482fdee8231f7 /net-misc
parentprofiles/features/musl: mask net-im/element-desktop-bin (diff)
downloadgentoo-c51a2927d2e9bcf2803771e32a95aac22a0f3a3b.tar.gz
gentoo-c51a2927d2e9bcf2803771e32a95aac22a0f3a3b.tar.bz2
gentoo-c51a2927d2e9bcf2803771e32a95aac22a0f3a3b.zip
net-misc/yt-dlp: add 2022.6.29
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/yt-dlp/Manifest1
-rw-r--r--net-misc/yt-dlp/yt-dlp-2022.6.29.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/Manifest b/net-misc/yt-dlp/Manifest
index b4490211a700..78dc5f11fc7b 100644
--- a/net-misc/yt-dlp/Manifest
+++ b/net-misc/yt-dlp/Manifest
@@ -1,2 +1,3 @@
DIST yt-dlp-2022.5.18.tar.gz 2277146 BLAKE2B 95237fcb12aef9d849e5cc5603baeb5b8e6f416db2dad04d8ea7408b966dcd0d05ad3e276342fb9cc3551293a569b48d2b806c360e95c9c96ffb17dff4cbeb9a SHA512 d0c11e6dba336124898e73234c5935386163af8a9dbbe3e2c38ec834ff631557a763e5224c30747dcffcf98364b95b7f1b6121c50ef91ed56653e2ce453548b5
DIST yt-dlp-2022.6.22.1.tar.gz 2314891 BLAKE2B 4c3e854f89281be9c8c301be0ebaf27434f04a6e26f7fe3bbb60e4d68d36605d5d2fce8ae9245c5e6421913bea90cbd4030d30babed81bdd9df56c3c73dfbcdc SHA512 0a0a4b25e0a75774bc659770af7d83a307d2ff4a3eef11c02ca422c0f4920ba47e02350cd72a4c4a4903aa7f97879b979c755318d3b48def6be738e09d72c3c6
+DIST yt-dlp-2022.6.29.tar.gz 2321677 BLAKE2B c1c6e18af961c7d433fae432ecf38feb28bff315ad9a3949c431f35f46a469460ade8a44e23f699d248dee1088bd507981479ab009c3e8152508c730ff146683 SHA512 f6832e70a73a3b787af9a9e2c4219bd593d2eb0e4c37a0d5696a5a11413a7230f4ca5e480db43713477fba6eae076c600ec98f24adb5c651fa5fbb9fdd83ad45
diff --git a/net-misc/yt-dlp/yt-dlp-2022.6.29.ebuild b/net-misc/yt-dlp/yt-dlp-2022.6.29.ebuild
new file mode 100644
index 000000000000..775abf17078d
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-2022.6.29.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit bash-completion-r1 distutils-r1 optfeature wrapper
+
+DESCRIPTION="youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp/"
+SRC_URI="mirror://pypi/${P::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ !net-misc/youtube-dl[-yt-dlp(-)]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # adjust requires for pycryptodome and optional dependencies (bug #828466)
+ sed -ri requirements.txt \
+ -e "s/^(pycryptodome)x/\1/" \
+ -e "/^(brotli.*|certifi|mutagen|websockets)/d" || die
+}
+
+python_test() {
+ epytest -m 'not download'
+}
+
+python_install_all() {
+ dodoc README.md Changelog.md supportedsites.md
+ doman yt-dlp.1
+
+ dobashcomp completions/bash/yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_yt-dlp
+
+ rm -r "${ED}"/usr/share/doc/yt_dlp || die
+
+ make_wrapper youtube-dl "yt-dlp --compat-options youtube-dl"
+}
+
+pkg_postinst() {
+ optfeature "various features (merging tracks, streamed content)" media-video/ffmpeg
+ has_version media-video/atomicparsley || # allow fallback but don't advertise
+ optfeature "embedding metadata thumbnails in MP4/M4A files" media-libs/mutagen
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
+ elog 'as "youtube-dl". This is strictly for compatibility and it is'
+ elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
+ fi
+}