summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-13 15:25:56 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-13 15:25:56 +0100
commitc7c4a47cc71ce36163a91610334bc694f7ad2caa (patch)
tree4b1ec3361f8c71e85bbe610f6e490f4a44980008 /net-misc
parentmedia-libs/opencollada: Removed old (diff)
downloadgentoo-c7c4a47cc71ce36163a91610334bc694f7ad2caa.tar.gz
gentoo-c7c4a47cc71ce36163a91610334bc694f7ad2caa.tar.bz2
gentoo-c7c4a47cc71ce36163a91610334bc694f7ad2caa.zip
net-misc/vinagre: Fix for GCC 10 / -fno-common
Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/vinagre/files/vinagre-3.22.0-gcc10-fno-common.patch22
-rw-r--r--net-misc/vinagre/vinagre-3.22.0-r3.ebuild5
2 files changed, 26 insertions, 1 deletions
diff --git a/net-misc/vinagre/files/vinagre-3.22.0-gcc10-fno-common.patch b/net-misc/vinagre/files/vinagre-3.22.0-gcc10-fno-common.patch
new file mode 100644
index 000000000000..d23ce4fa59f6
--- /dev/null
+++ b/net-misc/vinagre/files/vinagre-3.22.0-gcc10-fno-common.patch
@@ -0,0 +1,22 @@
+--- a/plugins/vnc/vinagre-vnc-connection.c
++++ b/plugins/vnc/vinagre-vnc-connection.c
+@@ -27,6 +27,8 @@
+ #include "vinagre-vnc-connection.h"
+ #include "vinagre-vala.h"
+
++gboolean scaling_command_line;
++
+ struct _VinagreVncConnectionPrivate
+ {
+ gchar *desktop_name;
+--- a/plugins/vnc/vinagre-vnc-connection.h
++++ b/plugins/vnc/vinagre-vnc-connection.h
+@@ -26,7 +26,7 @@
+
+ G_BEGIN_DECLS
+
+-gboolean scaling_command_line;
++extern gboolean scaling_command_line;
+
+ #define VINAGRE_TYPE_VNC_CONNECTION (vinagre_vnc_connection_get_type ())
+ #define VINAGRE_VNC_CONNECTION(obj) (G_TYPE_CHECK_INSTANCE_CAST ((obj), VINAGRE_TYPE_VNC_CONNECTION, VinagreVncConnection))
diff --git a/net-misc/vinagre/vinagre-3.22.0-r3.ebuild b/net-misc/vinagre/vinagre-3.22.0-r3.ebuild
index 681c6aac3fd8..dd6c7bc9f772 100644
--- a/net-misc/vinagre/vinagre-3.22.0-r3.ebuild
+++ b/net-misc/vinagre/vinagre-3.22.0-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -55,6 +55,9 @@ src_prepare() {
# https://bugzilla.gnome.org/show_bug.cgi?id=765444
eapply "${FILESDIR}"/${PN}-3.20.2-freerdp2.patch
eapply "${FILESDIR}"/${PN}-3.22.0-freerdp2-2.patch
+ # https://gitlab.gnome.org/GNOME/vinagre/merge_requests/8
+ eapply "${FILESDIR}"/${PN}-3.22.0-gcc10-fno-common.patch
+
vala_src_prepare
eautoreconf
gnome2_src_prepare