summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-01-09 15:14:19 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-01-09 15:29:19 +0100
commitd0332d8b3cd140af14e8355f123017d76dc5f679 (patch)
tree89dde031c7f57a27e94ebe6c410a6540f8ca53ac /net-misc
parentgames-fps/eduke32: drop old version (diff)
downloadgentoo-d0332d8b3cd140af14e8355f123017d76dc5f679.tar.gz
gentoo-d0332d8b3cd140af14e8355f123017d76dc5f679.tar.bz2
gentoo-d0332d8b3cd140af14e8355f123017d76dc5f679.zip
net-misc/igmpproxy: bump to version 0.3
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/igmpproxy/Manifest1
-rw-r--r--net-misc/igmpproxy/igmpproxy-0.3.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/net-misc/igmpproxy/Manifest b/net-misc/igmpproxy/Manifest
index 53a0e07520d2..201e093e6a01 100644
--- a/net-misc/igmpproxy/Manifest
+++ b/net-misc/igmpproxy/Manifest
@@ -1 +1,2 @@
DIST igmpproxy-0.2.1_p20200508.tar.gz 43672 BLAKE2B 886e293a30ec8b0a6bdfee9a7858d6de67b42e71628a604b108909f7eac31cfb129648f6eb8c47cf6aeec4d0a078f5a7a0f4487737b4f9338f727445a4f94dac SHA512 f0929537cac30664ed94231b2b31098dccea53a3e0d5ddfc14ae5ab08fa116438a983d06c17f41d8fec69b94d0c8725eb23525c94813d78310f2f2e3c03bcbf7
+DIST igmpproxy-0.3.tar.gz 168403 BLAKE2B 4dd07936074fbd9b3c869851f5b592f1eec33109be78ee5a05b3658c26afb67c30379f7cc66dfa20af276aae0a1c21dbf5c9fd337c853d623b08126324b06561 SHA512 0b1deca544317e2f0b1ff550e5921e8d6f64565f7cd72b6210fc7d3d7c3a301875088687a31ca5a29d310b2931695bd7a77e41dc5685ab7175ea1d41fe9246af
diff --git a/net-misc/igmpproxy/igmpproxy-0.3.ebuild b/net-misc/igmpproxy/igmpproxy-0.3.ebuild
new file mode 100644
index 000000000000..b0dc2629ed3a
--- /dev/null
+++ b/net-misc/igmpproxy/igmpproxy-0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools linux-info systemd
+
+DESCRIPTION="A multicast routing daemon which uses IGMP forwarding"
+HOMEPAGE="https://github.com/pali/igmpproxy"
+SRC_URI="https://github.com/pali/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+
+CONFIG_CHECK="~IP_MULTICAST ~IP_MROUTE"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/igmpproxy.initd-r1 igmpproxy
+ systemd_dounit "${FILESDIR}"/"${PN}".service
+
+ newconfd "${FILESDIR}"/igmpproxy.confd igmpproxy
+}